cmd-F (find dialog) should mean search bookmarks when organizing bookmarks

VERIFIED DUPLICATE of bug 240760

Status

--
minor
VERIFIED DUPLICATE of bug 240760
14 years ago
13 years ago

People

(Reporter: jwinshell, Assigned: mikepinkerton)

Tracking

unspecified
Camino1.0
PowerPC
Mac OS X

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/125.4.2 (KHTML, like Gecko) Safari/125.9
Build Identifier: 

Cmd-F  (find) is muscle memory.  When a window is showing (organizing) bookmarks, cmd-F (find) 
currently does the wrong (useless) thing.  Instead cmd-F should just be an equivalent to the "search" 
widget at the bottom of the bookmark window.

Reproducible: Always
Steps to Reproduce:
1.  show bookmarks
2. cmd-F, as if using the find dialog to search bookmarks (currently wrong)
3. cmd-F should be equivalent to typing in the search widget at the bottom of the bookmarks pane
Actual Results:  
cmd-F (find dialog) does not work in bookmarks mode.

Expected Results:  
cmd-F should be equivalent to typing in the search widget at the bottom of the bookmarks pane

Comment 1

14 years ago
I think the whole relationship between tabs and the bookmarks window needs
tidying up. I'm forever pressing Close Tab in my toolbar to get rid of the
bookmarks only to find I've lost what I was previously browsing.

As for Apple+F's behaviour - I agree. It needs either disabling in bookmark
mode, or it needs to search the bookmarks.

Comment 2

14 years ago
We should make sure the find in page menu item is disabled when in bm mode.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Camino1.0
now that bug 174899 has been implemented, should we have cmd+F go into the
quicksearch field in the bookmarks/history manager?

Comment 4

13 years ago
Yeah, I vote for just focussing the quicksearch field.

*** This bug has been marked as a duplicate of 240760 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.