No cmd-key equivalent to open a selected bookmark in bookmark mode

RESOLVED FIXED in Camino1.0

Status

Camino Graveyard
Bookmarks
--
minor
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Jason Winshell, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino1.0
PowerPC
Mac OS X

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/125.4.2 (KHTML, like Gecko) Safari/125.9
Build Identifier: 2004091108 (v0.8+)

If a bookmark has been selected (highlighted) in the bookmarks window, there is no cmd-key to open 
the bookmark.  Enter or return has been mapped to editing the bookmark.   Currently only a double 
mouse-click can open (launch) the bookmark.  [Safari has same shortcoming].  Launching a bookmark 
is more common than editing it it.  There should be a keyboard shortcut.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
I agree - and the shortcut should be Apple + O

Comment 2

13 years ago
Command + O can't be use becuase we already use it for opening files (file menu).
I guess something like command+enter might do the trick as we will also use this
in the url field and search field to open url/search in a new tab or windoww
(pref related).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Camino1.0

Comment 3

13 years ago
Enter doing the edit is probably logical on the mac, by comparison with the
finder. Command + Enter is about the only option left to us, on the finder this
does nothing, but all the other variants result in the rename functionality.

Comment 4

13 years ago
Command-down arrow works (like the Finder), but it opens it in a tab (since the
command key is down).

Comment 5

12 years ago
How about right-arrow (like many RSS readers?)

Comment 6

12 years ago
Command-down arrow works already (just like the Finder).
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.