Last Comment Bug 259036 - Qt widget port
: Qt widget port
Status: VERIFIED FIXED
:
Product: Core Graveyard
Classification: Graveyard
Component: Ports: Qt (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: timeless
: Christian :Biesinger (don't email me, ping me on IRC)
:
Mentors:
Depends on:
Blocks: 259033
  Show dependency treegraph
 
Reported: 2004-09-12 17:10 PDT by Zack Rusin
Modified: 2008-07-31 01:11 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
widget/src/qt directory (25.11 KB, application/octet-stream)
2004-09-12 17:10 PDT, Zack Rusin
no flags Details
widget/src/qt dir (25.46 KB, application/x-tbz)
2004-09-17 18:33 PDT, Zack Rusin
no flags Details
Fixes the crash (25.47 KB, application/x-tbz)
2004-09-18 20:20 PDT, Zack Rusin
no flags Details
Adapt to current CVS (25.42 KB, application/x-tbz)
2004-09-25 16:15 PDT, Bernhard Rosenkraenzer
no flags Details
updated widget/src/qt directory (25.80 KB, application/x-tbz)
2004-09-26 11:11 PDT, Zack Rusin
no flags Details

Description Zack Rusin 2004-09-12 17:10:02 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7) Gecko/20040823 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7) Gecko/20040823 Firefox/0.9.3

This bug contains the widget/src/qt patch. 

Reproducible: Always
Steps to Reproduce:
Comment 1 Zack Rusin 2004-09-12 17:10:51 PDT
Created attachment 158688 [details]
widget/src/qt directory
Comment 2 Zack Rusin 2004-09-17 18:33:50 PDT
Created attachment 159277 [details]
widget/src/qt dir

Updated the patch to work with HEAD.
Comment 3 Christian :Biesinger (don't email me, ping me on IRC) 2004-09-18 08:13:10 PDT
ok, so once I implemented nsFontEnumeratorQt::GetDefaultFont with a no-op impl,
I got past the unresolved symbol; but now I crash at startup:

(gdb) bt
#0  0x419e273b in QApplication::construct () from /usr/lib/libqt.so.3
#1  0x419e2b65 in QApplication::QApplication () from /usr/lib/libqt.so.3
#2  0x41782e5a in nsAppShell::Create (this=0x8142e70, argc=0x0, argv=0x0)
    at /home/chb/mozilla/widget/src/qt/nsAppShell.cpp:73
#3  0x4173f4e9 in nsAppShellService::Initialize (this=0x8142dc8,
aCmdLineService=0x8142830,
    aNativeAppSupportOrSplashScreen=0x0) at
/home/chb/mozilla/xpfe/appshell/src/nsAppShellService.cpp:166
#4  0x0804dcb0 in main1 (argc=1, argv=0xbfffee94, nativeApp=0x0) at
/home/chb/mozilla/xpfe/bootstrap/nsAppRunner.cpp:1209
#5  0x0804ef93 in main (argc=1, argv=0xbfffee94) at
/home/chb/mozilla/xpfe/bootstrap/nsAppRunner.cpp:1799

I suppose Qt doesn't like null argc/argv.

The reason this is null is:
#3  0x4173f4e9 in nsAppShellService::Initialize (this=0x8142dc8,
aCmdLineService=0x8142830,
    aNativeAppSupportOrSplashScreen=0x0) at
/home/chb/mozilla/xpfe/appshell/src/nsAppShellService.cpp:166
166       rv = mAppShell->Create(0, nsnull);

My qt version:
qt3-non-mt-3.3.1-41.14
qt3-devel-3.3.1-33
qt3-devel-tools-3.3.1-32
qt3-3.3.1-36.16
Comment 4 Zack Rusin 2004-09-18 20:20:46 PDT
Created attachment 159368 [details]
Fixes the crash
Comment 5 Bernhard Rosenkraenzer 2004-09-25 16:15:19 PDT
Created attachment 160091 [details]
Adapt to current CVS

Adding new patch to make it compile with current CVS
Comment 6 Zack Rusin 2004-09-25 16:33:27 PDT
Thanks, but it won't make too much difference. I had this locally for a while
but I'm just rewritting lots of it so it won't make a difference. 
nsCommonWidget can't be the one receiving the events, the only object which
needs to propagate Qt events is the nsWindow and I'm exporting the dispatcher
there. Also it seems like the drawing widget needs to be different than our
window widget since otherwise we get event storms (e.g. a resize event is
received and Resize is called -> we resize internal widget -> resize signal from
Qt is received -> we dispatch resize event to Mozilla -> Resize is called... ).
Of course until this lands in CVS, and it doesn't look like it will happen
anytime soon, everyone will have to deal with my busy schedule at the moment :(
Comment 7 Zack Rusin 2004-09-26 11:11:15 PDT
Created attachment 160166 [details]
updated widget/src/qt directory

Some updated. Use with the new GFX patch.
Comment 8 Zack Rusin 2004-10-10 21:18:20 PDT
Code is now in CVS.
Comment 9 Christian :Biesinger (don't email me, ping me on IRC) 2004-10-15 08:26:00 PDT
vrfy fixed. qt is now in the tree.

Note You need to log in before you can comment on or make changes to this bug.