Closed Bug 259039 Opened 17 years ago Closed 17 years ago

import bookmarks wizard doesn't display open file dialog (closes after choosing "from file")

Categories

(Firefox :: Bookmarks & History, defect)

PowerPC
macOS
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: david.poole, Assigned: quark29)

References

Details

(Keywords: fixed-aviary1.0, regression)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040910 Firefox/0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040910 Firefox/0.10

When trying to use the import bookmark file functionality, I'm never prompted to
choose a file.  The wizard displays, I select from file, click the next button
and the wizard closes returning me to the bookmarks manager window.

Reproducible: Always
Steps to Reproduce:
1. From the Bookmarks Manager, Select File and choose Import.  The Import wizard
appears.
2. Select the From File radio button and click next.
Actual Results:  
Nothing.

Expected Results:  
It should have shown a open file dialog to allow choosing of file.
Confirmed with 20040911 Firefox/0.10 on Mac.
Not reproduced with 20040911 Firefox/0.10 on WinNT.
This is Mac only.

marking New and requesting blocking-aviary1.0mac.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.0mac?
I'm getting the same thing in the bookmarks manager.

Additionally, choosing "File->Import..." is also broken, the next button on the
first page is unresponsive, and I must click "Cancel" to exit the dialog.
Severity: normal → major
Flags: blocking-aviary1.0?
QA Contact: mconnor → bugs.mano
Is there anyone on a Mac that could help me debug this?  File -> Import being
broken might help me, but if I can't see a problem it'll be hard to fix it. 
I'll try looking this afternoon.
Simple "marketing" comment:  This bug is the major reason I can't commit to
giving Firefox a full-fledged trial - my accumulated bookmarks are too valuable!
(In reply to comment #3)

I have a debug build here, but i'm not sure what should be debugged :-/
Some things to check out.

JS Console.  When using File -> Import (make sure to try the faulty 'Next'
button), does anything pop up?  How about when you've gone through the Bookmark
Manager's Import and gotten nothing?

Debug Console.  Same as above.  You see anything in the debug console?

After Bookmarks Manager -> Import, with the Migration Wizard open, try:
DOMi -> Inspect a Window -> Migration Wizard ->Object - Javascript Object
Check out 'target -> commandDispatcher -> focusedWindow -> arguments'
and '-> arguments -> 0'
What are those values set to?

Select From File and hit next, then try:    
DOMi -> Inspect a Window -> Bookmarks Manager ->Object - Javascript Object
    'target -> commandDispatcher -> focusedWindow -> fromFile'
What is that value set to?

Additionally, is Bookmarks Manager -> Import working when not choosing 'From File'?
Two problems:

1. File--Import--Import Wizard (Import Settings and Data from) shows up but
clicking Next yield nothing, can only cancel.

2. Bookmarks--Manage Bookmarks---File Import--Import Wizard (Import Bookmarks
from...from Files...) clicking Next close the dialog box.

I have done a complete uninstall, now I have a copy of Safari bookmark and a
copy of Firefox bookmark, but copying to Profile/Bookmark can only resolve one.

Where can I download a copy of debug-build to help?
hi ryan,

here we go. Bug reproduces with the 1.0 preview and with today's nightly build.

- no output in JS console
- i can't find a debug console
- when i try to open DOMi, it'll just mark the Tools window (inverted) and won't
open anything -- while the import wiz is open. (that's another bug!)
- when Domi open before import wiz, the two attributes you asked for are

bookmarks
and
"bookmarks"

- when i tried to hit 'from file' and 'ok', i couldn't find the 'fromFile'
property at all. When I tried to do it again, using the Find function a couple
times and maybe doubleclikcing on some stuff in the DomI, it crashed the whole
process. I tried again but now I can't even get the DomI to display the correct
object (the one of the wizard window)

This is when I gave up.

Bookmarks Manager does import some  Netscape bookmarks.

When none of the radio buttons is chosen, the 'next' button is already active
(which is a UI bug!!), but cannot be clicked. (very bad UI bug.)

Well, sarcastic comment ahead: if people cannot migrate their bookmarks, who the
hell would switch from another browser to Firefox? And because I am not getting
a proper error message and also no decent UI feedback  in the migration wizard,
I am getting a really bad user experience -- not good for a first time Firefox
user on a Mac :-(
Flags: blocking-aviary1.0mac? → blocking-aviary1.0mac+
David Reitter:
1)Debug Console is limited to a debug build.  If you only use release builds or
nightly builds, don't worry about this.
2)While I agree this should block releases, it's not up to me or you to decide,
it's up to drivers.
3)Thanks for the testing.

Can someone confirm fromFile not existing?  And is the File->Import problems a
symptop of no default value or just not working at all?  The default value issue
should be split into a seperate bug report.
Flags: blocking-aviary1.0mac+ → blocking-aviary1.0mac?
*** Bug 260915 has been marked as a duplicate of this bug. ***
*** Bug 261451 has been marked as a duplicate of this bug. ***
It looks to me (user) like it's separate from no default value. The no default
value makes the next button do nothing, but when you select "from file", next
closes the dialog without an open file dialog.
*** Bug 261931 has been marked as a duplicate of this bug. ***
Ben checked in something that modifies how "fromfile" works from bug 249302, can
someone test this on the next round of Mac nightlies?
I just downloaded a nightly, and the importation of a bookmark file seems to
have worked ok. I imported  a bookmark file that I had exported from firefox and
the file "seemed" to have been imported ok. I however did not get  a wizard, or
the option to select the source of the importation. But this fix works for me. 
May I close the bug? 
Which nightly did you download?  Would like to verify, but I cannot find a
nightly which doesn't crash or allows an import.
(In reply to comment #14)
> Ben checked in something that modifies how "fromfile" works from bug 249302, can
> someone test this on the next round of Mac nightlies?

Not fixed at all, you probably tested with a trunk build
> After Bookmarks Manager -> Import, with the Migration Wizard open, try:
> DOMi -> Inspect a Window -> Migration Wizard ->Object - Javascript Object
> Check out 'target -> commandDispatcher -> focusedWindow -> arguments'
> and '-> arguments -> 0'
> What are those values set to?

Actually, it seems as the window doesn't have "arguments", in other words this
check:

if ("arguments" in window && window.arguments.length > 1)

returns false
Keywords: regression
Summary: import bookmarks wizard doesn't display open file dialog → import bookmarks wizard doesn't display open file dialog (closes after choosing "from file")
doesn't block 1.0, blocks 1.0 Mac
Flags: blocking-aviary1.0mac?
Flags: blocking-aviary1.0mac+
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0-
(aka "Sheet").

From some reaosn, non-modal (note: "dependent" has no effect on mac) dialogs
don't have the arug' array on mac.

I hope we'll have something better for 1.0mac.
Assignee: quark29 → bugs.mano
QA Contact: bugs.mano → bugs
Comment on attachment 160654 [details] [diff] [review]
Ugly workaround  (aviary only): make it a modal dialog on mac

The patch on bug 25040 has been just sr+ed.
Attachment #160654 - Attachment is obsolete: true
Attachment #160654 - Flags: review?(mconnor)
Comment on attachment 160654 [details] [diff] [review]
Ugly workaround  (aviary only): make it a modal dialog on mac

bz says his patch isn't branch safe.
Attachment #160654 - Attachment description: Ugly workaround: make it a modal dialog on mac → Ugly workaround (aviary only): make it a modal dialog on mac
Attachment #160654 - Attachment is obsolete: false
Attachment #160654 - Flags: review?(mconnor)
*** Bug 262418 has been marked as a duplicate of this bug. ***
Attached patch don't use arguments (obsolete) — Splinter Review
Hot potato, hot potato.

This patch switches the check from arguments to window.opener, so it completely
sidesteps the arguments bug.  Auto-migrate checks are reverted to the
pre-bookmarks method (simplified).  Ben making init() call onImportShowPage()
allows for further simplification.
If this gets review I would recommend not putting it into trunk for the time
being, if only to allow us to have something to test the patch in bug 25040.
Assignee: bugs.mano → quark29
Attachment #160654 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Mano, would you mind testing this patch for Macs?  I've testing automigration,
File -> Import, and Bookmarks Import on Win32.
Attachment #160654 - Flags: review?(mconnor)
I will test it later today, thanks Ryan.
Comment on attachment 160751 [details] [diff] [review]
don't use arguments

we may have to go Mano's route, I believe not being modal is creating a
race-condition that no user could possible win at.
Attachment #160751 - Attachment is obsolete: true
Comment on attachment 160654 [details] [diff] [review]
Ugly workaround  (aviary only): make it a modal dialog on mac

Restoring Mano's patch, it's the simplest solution that can go in quickly.
Attachment #160654 - Attachment is obsolete: false
Attachment #160654 - Flags: review?(vladimir)
When I applied the patch for bug 25040 to my branch, it did not fix the problem.
 I believe there's a race condition at importBookmarks -
http://lxr.mozilla.org/aviarybranch/source/browser/components/bookmarks/content/bookmarks.js#707
If non-modal windows are threaded, the if() clause will fail its check
immediately after spawning the new window.  Modal windows appear to not be threaded.

Besides making it modal, the two solutions I see involve a wait condition or
moving all of importBookmarksFromFile (and what it's dependent on) to migration.js.
Attachment #160654 - Flags: review?(vladimir)
Attachment #160654 - Flags: review+
Attachment #160654 - Flags: approval-aviary?
Comment on attachment 160654 [details] [diff] [review]
Ugly workaround  (aviary only): make it a modal dialog on mac

a=ben@mozilla.org
Attachment #160654 - Flags: approval-aviary? → approval-aviary+
in on aviary, thanks!
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Keywords: fixed-aviary1.0
*** Bug 263398 has been marked as a duplicate of this bug. ***
*** Bug 264463 has been marked as a duplicate of this bug. ***
*** Bug 264775 has been marked as a duplicate of this bug. ***
*** Bug 266407 has been marked as a duplicate of this bug. ***
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060421 Minefield/3.0a1

I'm also seeing this bug.
You need to log in before you can comment on or make changes to this bug.