RESOLVED INVALID

Status

SeaMonkey
General
--
critical
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Daniel Barrett, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040803

Hit http://visualroute.visualware.com. Browser instantly crashes before any part
of the page is displayed: the browser window closes and nothing happens
afterward (i.e., no feedback box appears or anything).

Reproducible: Always
Steps to Reproduce:
1. Hit http://visualroute.visualware.com
2. Browser instantly crashes.
Actual Results:  
Browser crash.

Expected Results:  
Load the page.

Here is the source of the page as captured by "wget
http://visualroute.visualware.com":

<html>
<head>
<script>
var d=1;
var s=new Date();
function il(){
if (d){
	d=0;
	(new Image()).src='http://visualresponse.visualware.com/vvv?r='+((new
Date()).getTime()-window.s.getTime()+'&x=vus&s=1&d='+(new Date()).getTime());
	(new Image()).src='http://desktopresponse.visualware.com/vvv?r='+((new
Date()).getTime()-window.s.getTime()+'&x=vrusdemo&s=1&d='+(new Date()).getTime());
	(new Image()).src='http://82.165.240.201/vvv?r='+((new
Date()).getTime()-window.s.getTime()+'&x=vrusdemo&s=1&d='+(new Date()).getTime());
	(new Image()).src='http://82.165.240.203/vvv?r='+((new
Date()).getTime()-window.s.getTime()+'&x=vrusdemo&s=1&d='+(new Date()).getTime());
	}
}
</script>
<title>VisualRoute Server: Virginia, USA - trace IP address, traceroute, trace
route, IP locator, IP tracer</title>
<meta name="description" content="See traceroute (tracert), ping, and IP address
location information from our VisualRoute Server in Dulles, Virginia, USA, to
any URL or domain you select.">
<meta name="keywords" content="traceroute, ping, tracert, whois, network
latency, packet loss, visualroute, trace route, ip routing, ip lookup, ip trace,
ip track, ip tracking, connectivity, visual trace, ip finder, ip identification,
network diagnotics, reverse dns, ping tool, ping utility">
<style TYPE="text/css"> body {font-family: Verdana;}
                                                     A.cool {
                                                     color:blue;
                                                     text-decoration:none;
                                                     font-weight: normal
                                                     }
                                                     A.cool:Visited {color:blue}
                                                     A.cool:Active {color:blue}
                                                     A.cool:Hover
{color:red}</style>
<script language="JavaScript">
if (self!=top) {
  top.location.href = self.location.href;
  }
if (location.href.indexOf('?go')>0) {
  top.location.href = 'http://www.visualware.com/promo/go.html';
  }
</script> 
</head>
<body onLoad=il() topmargin=0 leftmargin=0 marginwidth=0 marginheight=0
bgcolor="FFFFFF" text="#000000" link="#0000FF" alink="#FF0000" vlink="#0000FF">

<!--begin header-->
<table width="100%" cellpadding=0 cellspacing=0 border=0>
<tr>
<td width=265><a href="http://www.visualware.com"><img src="logo.gif" width=265
height=48 border=0 alt="Visualware"></a></td>
<td valign=bottom align=center><font size="+2"
color="blue">&nbsp;VisualRoute&nbsp;Server&nbsp;<br>
<font size="-1">Virginia, USA</font></td>
<td valign=bottom align=right><a href="http://www.mycooltools.com"><img
src="mycooltools.gif" width="240" height="42" border=0></a></td>
</tr>
<tr><td colspan=3 bgcolor="#800000"><img src="s1.gif" width=500 height=2></td></tr>
</table>
<!--end header-->

<table border=0 cellspacing=0 cellpadding=5>
<tr>
<td valign="top">


<!--VisualRoute-->
<table width=170 border=1 cellpadding=5 cellspacing=0>
  <tr>
   <td bgcolor="#FFFFD0" align="center">
    <small><font color="red"><b><a
href="http://www.visualware.com/personal/products/visualroute/index.html">
    VisualRoute</a></b></font></small>
    <br>
   </td>
  </tr>
  <tr>
   <td bgcolor="#F8F8F8">
   
   <font size="-2">Quickly identify the source of <b>connectivity problems</b> and 
   <b>locate Internet abusers.<br></b>
   </font>
   
   <center><a
href="http://www.visualware.com/personal/products/visualroute/index.html"><img
src="vr-box_100x122.gif" width="100" height="122" border="0" alt="visual trace
route"></a><br>
   <font size=-2 color="red"><a
href="http://www.visualware.com/personal/purchase/index.html">Save with
VisualRoute product bundles</a>!</font></center>


 </td></tr></table><br>

<!--CallerIP-->
<table width=170 border=1 cellpadding=5 cellspacing=0>
  <tr>
   <td bgcolor="#FFFFD0" align="center">
	<small><font color="red"><b>NEW! <a
href="http://www.visualware.com/personal/products/callerip/index.html">CallerIP</a></b></font></small><br>
	</td>
  </tr>
  <tr>
   <td bgcolor="#F8F8F8"><font size="-2"><b>CallerID for the Internet!</b> See
who is connecting to your system and where they are located<b>.<br>
									</b></font>
								<center><a
href="http://www.visualware.com/personal/products/callerip/index.html"><img
src="CIPbox_100x122.gif" width="100" height="122" border="0" alt="Locate IP
addresses with CallerIP"></a><br>
									</center>
							</td></tr></table>




  <!--eMailTrackerPro-->
<br><table width=170 border=1 cellpadding=5 cellspacing=0>
 <tr><td bgcolor="#FFFFD0" align="center">
  <font color="red"><b><small><a
href="http://www.visualware.com/personal/products/emailtrackerpro/index.html">eMailTrackerPro</a></b></font>
 </td></tr><tr><td bgcolor="#F8F8F8">
<font size="-2">
<b></b>Email analysis tool <b>traces emails back to the sender</b>. 
  <center><a
href="http://www.visualware.com/personal/products/emailtrackerpro/index.html"><img
src="emt-box_100x123.gif" width="100" height="122" border="0" alt="email
tracer"></a><a
href="http://www.visualware.com/whitepapers/tutorials/email.html"><br>See our
 on-line tutorial</a>
 on how to trace emails.</center>
 </font>

 </td></tr></table><br>

   <!--Quick Links-->
<table width=170 border=1 cellpadding=5 cellspacing=0>
 <tr><td bgcolor="#FFFFD0" align="center">
<font color="red"><b><small>Quick Links</small></b></font>
 </td></tr><tr><td bgcolor="#F8F8F8">

<font size="-2">
 <a href="http://www.visualware.com">Visualware Home</a><br>
Solutions for:<br>
 <a href="http://www.visualware.com/personal/index.html">Home/Home Office<br>
 <a href="http://www.visualware.com/business/index.html">Businesses<br>
 <a href="http://www.visualware.com/enterprise/index.html">Enterprises<br>
 </font>

 </td></tr></table>

   <!--VisualLookout
<br><table width=170 border=1 cellpadding=5 cellspacing=0>
 <tr><td bgcolor="#FFFFD0" align="center">
  <font color="red"><b><small><a
href="http://www.visualware.com/personal/products/visuallookout/index.html">VisualLookout</a></b><br></font>
 </td></tr><tr><td bgcolor="#F8F8F8">

<a
href="http://www.visualware.com/personal/products/visuallookout/index.html"><img
src="visuallookout.gif" align="left" width="32" height="32" border="0"
alt=""><font size="-2"></a>
<font size="-2">
 <a
href="http://www.visualware.com/personal/products/visuallookout/index.html"><b>VisualLookout</b></a>
 <b>monitors open ports on your system</b> that firewalls often do not protect,
including automated capture of connection activity. Features include
identification of IP address country of origin, and email alerts to notify you
of suspicious activity.
 </font>

 </td></tr></table>
-->


 
 <!--Open Directory-->
 <font size="-2"><br></font>
 <center><img src="cool.gif" width=140 height=45></center>

 <!--PoweredBy-->
 <font size="-2"><br></font>
 <center><a href="http://www.visualware.com"><img alt="Powered by Visualware"
border=0 src="poweredby.gif" width=120 height=30></a></center>


</td>

<td width=600 valign="top">
<small>

<!--SPECIAL-->

<div align="center"></div>
 <table border=1 cellpadding=10 cellspacing=0>
 <tr><td bgcolor="#FFFFD0"><font color="red" size="-2"><b>NEW! <a
href="http://services.visualware.com/demo/visualroute/index.html">VisualRoute
Web Service</a></b></font><font size="-2">
provides you easy access whenever you need it! See Internet connectivity and IP
tracking information, plus instant domain WHOIS and network provider lookups.
Only $9.95/month! 
 <a href="http://services.visualware.com/purchase/index.html">Online
Subscription Options</a> 
 </font>
 </td></tr></font></table><br>


<!--Start Promo
<center>
<a href="http://www.wugnet.com/shareware/spow.asp?ID=557" TARGET="_blank">
<img src="emt3_wugnet468x60.gif" width="468" height="60" border="2" alt="Trace
emails to the sender with eMailTrackerPro">
</a>
</center>
-->

<p><center><b>Test Internet Connectivity and Trace IP Addresses</b><br></center>
<font size="-2">
This <a
href="http://www.visualware.com/personal/products/visualroute/index.html">VisualRoute</a>
Server provides a graphical traceroute from this server to any other network
device you choose, useful for <font color="blue">pinpointing network
connectivity</font> problems
and <font color="blue">identifying IP addresses</font>. To use, follow these
easy steps:<br>
1. Register and login. Your one-time registration includes use of all <a
href="http://www.mycooltools.com">MyCoolTools</a> services and subscription to
the Visualware newsletter. <br>
2. To trace back to your computer, select the button with your IP address below.
<br>
3. To trace to any other network device, enter the host name (ie.
www.visualware.com) or IP address below and press the Enter key. <br>
<font color="blue">To try the full-featured version including worldwide Whois
lookups,
<a href="http://www.visualware.com/personal/download/index.html"><b>download</b></a>
your own 15-day evaluation copy today! </font>
<br>

</small>
<font size="-2"><br></font>
 <table border=1 cellspacing=0 cellpadding=0 width=600>
 <tr><td><applet archive="VisualRouteApplet.jar" code="VisualRouteApplet.class"
width=600 height=800 MAYSCRIPT>
 <param name="allowgo" value="no">
 <param name="limitreachedurl"
value="http://services.visualware.com/demo/visualroute/limitreached.html"></param>
    <center><font size="+3" color="red"><br>
    Java support is required<br>
    <a href="http://www.java.com">http://www.java.com</a><br>
    <br>
    </font></center>
 </applet></td></tr>
 </table>

<!--terms of use-->
<font size="-2"><center>
(By using this service, you agree to abide by our
<a href="http://www.visualware.com/demo/termsofuse.html" TARGET="_blank">Terms
of Use</a>)
</center></font>
<!--end terms of use-->


<center><font size="-2"><br>
&copy; 1997-2004 <a href="http://www.visualware.com">Visualware</a> Inc.  All
rights reserved.
<a href="http://www.visualware.com/company/contact.html">Contact Us</a>
</font></center>
</td>
<td valign=top>


<!--PageSleuth-->
<table width=170 border=1 cellpadding=5 cellspacing=0>
 <tr><td bgcolor="#FFFFD0" align="center">
<b><small>Are you losing web traffic due to slow page loading?
</small></b>
 </td></tr><tr><td bgcolor="#F8F8F8"><center>
<a href="http://pagesleuth.visualware.com"><img src="gauge.gif" width="150"
height="120" border="0" alt="Try the PageSleuth online demo"></a></center>
<font size="-2">
<b><a
href="http://www.visualware.com/business/products/pagesleuth/index.html">PageSleuth</a></b>
measures web page efficiency, including individual components of a page.
<center>
 <a href="http://pagesleuth.visualware.com"><b>Try the online
demo!</b></a></center> 
 </font>

 </td></tr></table><br>



<!--MySpeed-->
<table cellSpacing="0" cellPadding="5" width="170" border="1">
  <tbody>
    <tr>
      <td align="middle" bgColor="#FFFFD0">
       <center>
		<font color="red"><a href="http://myspeed.visualware.com"><small><b>Add
Internet Speed Testing to your website!</b></small></a></font></center>
      </td>
    </tr>
							<tr>
      <td  >
		<center><a href="http://www.visualware.com/business/products/myspeed/index.html">
      <img src="myspeed_150x107.gif" width="150" height="107" border="0"
alt="MySpeed Internet speed test"></a></center>
	<font size="-2">Provide bandwidth testing for your website visitors with
Visualware's popular <b>MySpeed Internet Speed Tester</b>. And implementation
couldn't be easier -- just add the MySpeed files to your existing Web server!<br>
									</font>
									<center>
										<font color="red" size=-2><a
href="http://www.visualware.com/business/products/myspeed/index.html">More
information</a>.</font></center>
								</td>
    </tr>
						</tbody>
</table><br>


<!--DesktopResponse
 <table width=170 border=1 cellpadding=5 cellspacing=0>
 <tr><td bgcolor="#FFFFD0" align="center">
 <b><small><a
href="http://www.visualware.com/enterprise/products/desktopresponse/index.html"><font
color="red">Desktop<br>Response</font></a></small></b>
 </td></tr><tr><td bgcolor="#F8F8F8">
 <a
href="http://www.visualware.com/enterprise/products/desktopresponse/index.html"><img
src="dtr.gif" align="left" width="32" height="32" border="0" alt="Real-time
service delivery reporting"></a><font size="-2">
      Measure the <b>exact time it takes for a Web page to be received by a
      customer anywhere in the world</b>.&nbsp; Reports by geographic location,
      URL, ASN and network carrier.&nbsp;
 </font>
 </td></tr></table><br>
-->

   <!--DesktopAnalyzer
<table width=170 border=1 cellpadding=1 cellspacing=0>
 <tr><td bgcolor="#FFFFD0" align="center">
<b><a
href="http://www.visualware.com/enterprise/products/desktopanalyzer/index.html"><font
color="red"><small>DesktopAnalyzer</small></font></a></b>
 </td></tr><tr><td bgcolor="#F8F8F8">
<a
href="http://www.visualware.com/enterprise/products/desktopanalyzer/index.html"><img
src="dta.gif" align="left" width="32" height="32" border="0" alt="Validate
remote desktop configurations"></a>
      <font size="-2">Help your support personnel quickly <b>isolate performance
      and configuration problems at the customer's desktop</b>. </font>

 </td></tr></table><br>
 -->



   <!--DesktopProfile
<table width=170 border=1 cellpadding=1 cellspacing=0>
 <tr><td bgcolor="#FFFFD0" align="center">
<b><small><a
href="http://www.visualware.com/enterprise/products/desktopprofile/index.html"><font
color="#FF0000">DesktopProfile</font></a></small></b>
 </td></tr><tr><td bgcolor="#F8F8F8">
<a href="http://www.visualware.com/enterprise/products/desktopprofile/index.html">
<img src="vipr.gif" align="left" width="32" height="32" border="0" alt=""></a>
 <font size="-2"><b>Synthetic measurement of critical customer services</b> with
system
 and network resource utilization.
</font>
 </td></tr></table><br>
 -->

 <!--The Five Zones

 <table width=170 border=1 cellpadding=1 cellspacing=0>
 <tr><td bgcolor="#FFFFD0" align="center">
 <b><small><a
href="http://www.visualware.com/whitepapers/technical/entzones.html"
TARGET="_blank"><font color="#FF0000">The Five Zones</font></a></small></b>
 </td></tr><tr><td bgcolor="#F8F8F8">
<font size="-2">
 Understanding and managing the customer experience for Internet business
 applications is a difficult process. <a
href="http://www.visualware.com/whitepapers/technical/entzones.html"
TARGET="_blank">Read how</a>
 <b> Visualware divides the
 &quot;end-to-end&quot; service delivery process into five distinct zones</b>
and provides targeted solutions for helping you manage the Internet customer
 experience.
 </font>
 </td></tr></table>
<br>
-->



 <!--Cool Links
<br>
 <table width=170 border=1 cellpadding=5 cellspacing=0>
 <tr><td bgcolor="#FFFFD0" align="center">
 <font color="red"><Small><b>Cool Links</b></small>
 </td></tr><tr><td bgcolor="#F8F8F8">

 <font size="-2">
 <a href="http://www.ep.net/">Exchange Points</a>
 <a href="http://www.traceroute.org">traceroute.org</a><br>
 <a href="http://www.tracert.com">tracert.com</a><br>
 <br>
 <a
href="http://www.visualware.com/whitepapers/tutorials/coollinks.html"><b>More
Cool Links...</b></a>
 </font>

 </td></tr></table>
-->

</td>

</tr></table>
<br>
</div>

<!--end-->
</body>
</html>

Comment 1

14 years ago
Do you still crash if you disable Java (under Preferences -> Advanced)?
(Reporter)

Comment 2

14 years ago
Disabling Java (Preferences -> Advanced) makes the problem go away.

Comment 3

14 years ago
what version of java do you have installed?
do you crash on all java applets or just this one?
do you have the java plugin properly installed (symlinked, not copied)?
Keywords: crash
(Reporter)

Comment 4

14 years ago
>what version of java do you have installed?

From about:plugins:
Java(TM) Plug-in 1.4.2_03-b02

>do you crash on all java applets or just this one?

Hmmm... I just tried another one and crashed. So I guess, all Java apps.

>do you have the java plugin properly installed (symlinked, not copied)?

I did a plain vanilla install of Mozilla 1.7.2 on SuSE Linux 9.1. The contents
of the plugin directory are:

$  ls -l /usr/local/mozilla/plugins/
total 2222
-rwxr-xr-x  1 root root     856 Aug  5 23:31 flashplayer.xpt
-rwxr-xr-x  1 root root 1617848 Aug  5 23:31 libflashplayer.so
-rwxr-xr-x  1 root root  281904 Aug  5 23:31 libjavaplugin_oji.so
-rwxr-xr-x  1 root root   32314 Aug  5 23:31 libnptcl3.0.so
-rwxr-xr-x  1 root root   20864 Aug  3 13:05 libnullplugin.so
-rwxr-xr-x  1 root root   31572 Aug  5 23:31 mozplugger.so
-rw-r--r--  1 root root  129611 Aug  5 23:31 nppdf.so
-rw-r--r--  1 root root    4139 Aug  5 23:31 raclass.zip
-rwxr-xr-x  1 root root  138640 Aug  5 23:31 rpnp.so

so the Java plugin is a copy, not a symlink. I don't believe I changed anything
in this directory since installation, so this is how it got installed via the
Mozilla installer.

Comment 5

14 years ago
the Mozilla installer didn't put those plugins there (except libnullplugin.so).
 the JRE plugin has to be symlinked to work:
http://plugindoc.mozdev.org/linux.html#Java

resolving INVALID -- this is not a Mozilla bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

14 years ago
But Mozilla crashed. Even when an app is misconfigured it should exit
gracefully, not crash.  Doesn't that make it a Mozilla bug? 

Comment 7

14 years ago
plugins act as libraries to Mozilla.  they are effectively part of Mozilla and
Sun's plugin doesn't crash, it actually calls exit(), so there's really nothing
Mozilla can do.  there are bugs to safe-guard against such things, but you'd be
better off complaining to Sun.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.