add message filter "dont download from server", "leave on server" or "ignore"

RESOLVED DUPLICATE of bug 74430

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 74430
14 years ago
10 years ago

People

(Reporter: gerold.meisinger-reg, Assigned: Scott MacGregor)

Tracking

Other Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

from my ISP i got only ONE email adress, but several aliases. every one in my
family uses one alias. when i download mail from that email adress, i also get
the mails from my family. in outlook express, there is an filter called "dont
download from server", which leaves or ignores this mail. on my computer their
mails are filtered out. on an other computer my mails are filtered out, so
everyone only gets his/her mails.

=> add a message filter which leaves, ignores or dont download a mail from the
server (or however you want to call it)

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
I would also benefit from the "Do not download from Server" filter. Because it
isn't there, we have had to revert back to OE - and are unable to pass on the
recommendation to others who we know rely on this filter command.
Please, could someone try and resolve this in time for the next release. Cheers!

Updated

13 years ago
Component: Preferences → MailNews: Filters
Product: Thunderbird → Core
Version: unspecified → Other Branch

Comment 2

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3
> 
> from my ISP i got only ONE email adress, but several aliases. every one in my
> family uses one alias. when i download mail from that email adress, i also get
> the mails from my family. in outlook express, there is an filter called "dont
> download from server", which leaves or ignores this mail. on my computer their
> mails are filtered out. on an other computer my mails are filtered out, so
> everyone only gets his/her mails.
> 
> => add a message filter which leaves, ignores or dont download a mail from the
> server (or however you want to call it)
> 
> Reproducible: Always
> Steps to Reproduce:
> 1.
> 2.
> 3.

I think you can solve this using Header Only downloads. For headers that you
don't want to receive, set a Filter action "Delete the message". This will only
delete the local header, not the full body on the server. Then after the rest of
the headers are downloaded, you can get their full message bodies and none of
the headers you didn't want will get downloaded.

Comment 3

13 years ago
Ah, found it... bug 74430

*** This bug has been marked as a duplicate of 74430 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.