arrow keys in editor don't work

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
blocker
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: blizzard, Assigned: Scott MacGregor)

Tracking

unspecified
Thunderbird0.8
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Build is on Monday, Sept 13th off the aviary branch.

When editing a piece of email the arrow keys don't work.  i.e. pressing
up/down/right/left don't result in any movement of the cursor position.

Updated

14 years ago
Flags: blocking-aviary1.0PR?
(Assignee)

Comment 1

14 years ago
Yeeks this could be bad. We're about to release 0.8.

Brian, do yo you think this issue is related to the GTK2 keybinding changes for
editor that landed Friday?
Severity: normal → blocker
Target Milestone: --- → Thunderbird0.8
(Assignee)

Comment 2

14 years ago
I think this issue was caused by the GTK2 keybindings bug: Bug #257405

It might be a duplicate of regression Bug #259011
(Assignee)

Comment 3

14 years ago
Chris, are you using GTK1 or GTK2? 
(Reporter)

Comment 4

14 years ago
I had to delete my compreg.dat in my thunderbird profile.  Bryner says
"SITUATION NORMAL, NOTHING TO SEE HERE.  HOW ARE YOU?"
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

14 years ago
OK, just to put some reasonable information here -

Bryner says that this happens if you don't use MOZILLA_OFFICIAL=1 when you build
(and I don't.)  I'd like brian to say why, if possible.  It wasn't made clear.

Updated

14 years ago
Flags: blocking-aviary1.0PR?
You need to log in before you can comment on or make changes to this bug.