Last Comment Bug 259186 - Print preview cuts off right hand side
: Print preview cuts off right hand side
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: Printing: Output (show other bugs)
: unspecified
: x86 Linux
: -- normal with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-13 16:32 PDT by jeff putnam
Modified: 2009-12-22 12:47 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot of the right-half of a print preview for a page (2.90 KB, image/png)
2006-01-19 13:14 PST, Rachel
no flags Details

Description jeff putnam 2004-09-13 16:32:29 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040413 Debian/1.6-5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040911 Firefox/0.10

I have a file with contents :
<html><body><p>foo foo foo ... (several hundred foo's) </p></body</html> 
This renders in the browser ok, but when I go to print preview it renders 19
"foo"s across then about half an "f".  This is with "shrink to fit" set and
otherwise default settings (I believe). 

I have not tried printing it. 

This behavior was observed on another page and duplicated with the foos.

Reproducible: Always
Steps to Reproduce:
1. open file 
2. open print preview on the file
3. stare at the half effed f's




Expected Results:  
The page should be formatted to fit the paper if at all possible.  Given no css
or other style requirements, the lines should be broken on word boundaries and
set for the printer.
Comment 1 Rachel 2005-07-08 10:04:52 PDT
I too notice this same problem.  Not only does print preview show less of what
actually prints, but with the default 0.5" left & right hand margins, a page
optimized for a full-screen 800x600 output (approx. 779 pixel width), will
cutoff a chunk of the right-hand side of the page.  The only way to get around
this is to set left & right hand margins to 0, although it gives you smaller
printed margins than IE (with normal 0.5" margins) just to fit everything on
your page without cutting anything off.  Just go to any major website, such as
weather.com for instance, then go to Print Preview (make sure your left & right
margins are the default 0.5), and see how it cuts off.  Note again that IE
margins set to 0.5 left & right do not cutoff the page.
Comment 2 Rachel 2005-07-08 10:27:45 PDT
(In reply to comment #1)
> Update: setting left margin to 0.3 and right margin to 0.1 in Firefox,
produces the same results as 0.5 left & right in IE.  I have since set my Page
Setup in Firefox as such, but I shouldn't have to do this now, should I?
Comment 3 Remi 2005-07-15 11:21:11 PDT
I verified it to happen on Windows XP, too, with Firefox 1.0.5.  I would agree
that you shouldn't have to adjust page margins (BTW when I change the margins
with your numbers I get good results- thanks).  This is definitely a bug.  I
received the same problem viewing this website: 

http://flagship2.vanguard.com/VGApp/hnw/VanguardViewsArticle?ArticleJSP=/freshness/News_and_Views/news_ALL_specialtaxnotice_01202005_ALL.jsp

If you open the website in IE and in Firefox and compare the print preview,
Firefox has a bug.

(In reply to comment #2)
> (In reply to comment #1)
> > Update: setting left margin to 0.3 and right margin to 0.1 in Firefox,
> produces the same results as 0.5 left & right in IE.  I have since set my Page
> Setup in Firefox as such, but I shouldn't have to do this now, should I?

Comment 4 Rachel 2005-07-22 10:29:53 PDT
(In reply to comment #3)

Another update: My previous posts were when I had Firefox 1.0.4 - sorry I forgot
to mention that.  I now upgraded to 1.0.6 and the print preview is even worse. 
Even if I set my left & right hand margins ALL the way to 0, the right-hand side
STILL cuts off.  The GOOD news, is, however, that despite print preview being
wrong, when I actually go to print, the printing uses the correct margins that I
specified.  This means that I can use the default 0.5 margins and when printed,
I actually have 0.5 margins.  This is not good for developing, however, because
lots of ink will have to be wasted by actually PRINTING documents, instead of
relying on print preview.  Therefore, print preview has the bug now, instead of
both print preview & print itself.
Comment 5 Rachel 2005-07-22 10:41:41 PDT
(In reply to comment #4)
I take that back - printing still has bugs too.  I tried that site that you
mentioned, and for that site, printing works fine but print preview doesn't.  In
other sites, such as lorman.com, however, margins are incorrect.  Furthermore,
take amazon.com for instance.  It has issues as well.  It seems to print fine,
in terms of margins that is, however both print & print preview only print the
small header portion of the page on page 1, and everything else gets shifted to
page 2, 3, etc.  Other sites do this to me as well, and sometimes through
exiting Print Preview, or exiting Firefox and then reopen it again, it'll show
the pages as normal, but I haven't figured out yet what causes these abnormal
pagination issues.
Comment 6 carl 2005-10-13 08:26:15 PDT
This happens to me as well when I try to put page into landscape or when I try
to change the scale.
Just for your info I am running windows 2000 sp4.
Comment 7 Rachel 2006-01-19 13:09:53 PST
Update - I am running 1.0.7 on WinXP SP2.  Print preview still cuts off the right-hand side, but if page is designed properly (i.e. table size is ~680px wide, including any padding or margins), it prints just fine.  I am attaching a somewhat weird behavior I had with several <p> tags within a table cell for which the <p> tags had 15px padding-right.
Comment 8 Rachel 2006-01-19 13:14:06 PST
Created attachment 208999 [details]
Screenshot of the right-half of a print preview for a page

This is the right half of a print preview screenshot, and you can clearly see 3 different paragraphs (I hope).  They each have 15px of right padding.  Notice how in the middle paragraph, the sentence goes all the way to the edge of the grey box (background for the TD cell).  There are no <br> tags, line breaks, white space, or anything like that in my code.  Yet when I print, it prints with 15px of padding, even on that sentence.  Odd, huh?
Comment 9 Stef 2006-09-14 06:46:10 PDT
This bug is still present in 1.5.0.6 :-(
Setting the paper to landscape sometimes solves the problem. In some cases, only copy/paste to word processor lets you print all of the text. Weird thing is it does not happen on all pages and when it happens, it is only in the print preview and the actual print, not in the normal browser window.
Comment 10 John 2007-08-07 03:46:33 PDT
Still prevailent in 2.0.0.x on all platforms (Linux/Windows/Mac) tested.
Comment 11 Michael 2007-08-22 00:02:23 PDT
Bug still present. FF 2.0.0.6, WinXP. 
For example try this link: http://plone.org/products/plone/features/3.0/referencemanual-all-pages
and open print preview. Some letters on the right side are cutted.
Comment 12 Matěj Cepl 2007-12-06 06:46:18 PST
maybe duplicate of bug 84223?
Comment 13 Speedo Goo 2007-12-26 20:07:44 PST
Same for me, latest 3 beta on Ubuntu.

The actual printed paper looks nice, but the preview removes one or two rightmost letters on most lines.

Observed on page
http://msdn.microsoft.com/msdnmag/issues/08/01/DSAccountManagement/default.aspx?loc=&print=true
Comment 14 Kevin Brosnan 2009-12-22 12:46:53 PST
I created a document with about 6000 foo's in it and cannot reproduce the text going over the right margin using Firefox 1 through 3.7pre. 

The vanguard url is dead.

The plone page in comment 11 works for me using Firefox 2 and newer, breaks using Firefox 1.5 and older. 

I can't get the ms page to break using Firefox 1.5 or older so I suspect the page has been redesigned since comment 13 was added.

Marking works for me since there is no test case that shows this on a trunk build. Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091222 Minefield/3.7a1pre

Note You need to log in before you can comment on or make changes to this bug.