EditComponents -> Add Components page fails to load complete

RESOLVED WORKSFORME

Status

()

Bugzilla
Administration
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Emil Jeyaratnam, Unassigned)

Tracking

unspecified
Other
Linux
Bug Flags:
blocking2.20 +

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
Build Identifier: 2.16.5

- When trying to Add a Component to a product (EditComponent, action=Add), the 
page fails to load completely.
- The page stops loading on "Initial Owner" - without displaying the drop-down 
box, seeming to fail on the BuildUserElement function.
- This functionality has been working till now. Wondering whether it could be a 
database size issue as there are many products and components already.

Reproducible: Always
Steps to Reproduce:
1. Either Create a new Product/or Edit existing product
2. Add Component
3.

Actual Results:  
The EditComponent (action=Add) page stops loading after displaying the 
text "Initial Owner". Note: The drop-down box is NOT displayed.

Expected Results:  
Loaded the page completely and wait for user to enter fields and submit

Comment 1

14 years ago
I didn't think that dropdowns had made it to editcomponents in CVS yet?? (It is
in the patch on bug#255425, but I really should split that patch up into smaller
chunks for reviewing purposes.)

Is this from CVS, or a specific release of Bugzilla?
(Reporter)

Comment 2

14 years ago
It is from CVS. The drop down is for initial owner. Thanks very much for your 
feedback.

Comment 3

14 years ago
(In reply to comment #2)
> It is from CVS. The drop down is for initial owner. Thanks very much for your 
> feedback.

Have you (or anyone else) applied any patches locally?

Looking at the CVS trunk, here:

http://webtools.mozilla.org/bonsai/cvsblame.cgi?file=mozilla/webtools/bugzilla/template/en/default/admin/components/create.html.tmpl&rev=&root=/cvsroot

There is no dropdown for the initial owner field when creating a component.

What happens if you do a 'cvs diff' in the
'template/en/default/admin/components' directory of your bugzilla tree?

Your server logs should tell you more about why the page stopped loading. Do
they say anything helpful?
(Reporter)

Comment 4

14 years ago
Sorry, yes there are patches applied.

I have done some trouble shooting/hacking of my own, and found that if there 
are any more than 26 users in the database, this problem occurs!!! As long as 
there are 26 or less profiles, it works fine!

Am I going crazy?

Comment 5

14 years ago
I'd like to mark this as invalid, as it is not a bug in Bugzilla, but it is a
problem with a local patch. 

However, I am trying to finish up the patch to officially add the user dropdown
support to editcomponents first, and I will try and test with > 26 people when I
do that.  

Do you have similar problems with the other user dropdowns, when assigning bugs,
for example?
(Reporter)

Comment 6

14 years ago
It's only in that one page, believe it or not... very weird. Is there anything 
obvious you can see that may be causing it, so I can have the clients site 
working again?

Thanks again for your responses.

I will attach the file.
Check your error log.  It's possible that there are warnings getting printed to
the error log for each user as it loads the user list.  Some versions of Apache
have been known to hang if too much data gets dumped to the error_log during the
same request.
This is a 2.20 blocker if it's actually happening.  Can anyone reproduce this?
Assignee: justdave → administration
Flags: blocking2.20+
QA Contact: mattyt-bugzilla → default-qa
Target Milestone: --- → Bugzilla 2.20

Comment 9

13 years ago
Yeah, Emil, please answer Dave's question about the error_log -- that's what I
would also suspect.

Comment 10

13 years ago
Reporter, can you reproduce this bug without all your local patches applied? If
not, please mark this bug as INVALID. Else try to upgrade your installation.

Comment 11

13 years ago
No answer from the reporter for more than one month and nobody else, including
myself, is able to reproduce this bug using usemenuforusers turned either on or
off. Moreover, the reporter admitted he modified the code locally and that the
problem only occured here, so the problem cannot occur in User::get_userlist()
else other pages would be affected too. So marking this bug as WFM.

Reopen if you have new informations.
Severity: critical → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Target Milestone: Bugzilla 2.20 → ---
You need to log in before you can comment on or make changes to this bug.