Disabled Extensions "not compatible with Firefox 0.10" Wrong Version Number

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
11 years ago

People

(Reporter: lachlan.hunt, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

In the extension manager, after upgrading from Firefox 0.9.3 to 1.0PR,
incompatible extensions are disabled, as expected, but the description says.

  Disabled - not compatible with Firefox 0.10

This should say

  Disabled - not compatible with Firefox 1.0

Reproducible: Always
Steps to Reproduce:
1. With version 0.9.3 installed, install an extension that is not compatible
with 1.0PR.
eg. Some extensions I have that are not compatible include:
Allo Right-Click 0.1, BlankLast 0.4, Copy Plain Text 0.1, googlebar 0.9.0.28, etc.

2. Upgrade to Firefox 1.0PR
3. After firfox checks for updates and loads, launch the extension manager
4. Disabled extensions will be listed with that description I gave above with
the incorrect version number.
Actual Results:  
Firefox version number is incorrect, listed as 0.10

Expected Results:  
Should be listed as 1.0

Comment 1

14 years ago
Actually, the internal version number is still 0.10, not yet 1.0. See bug 257045.
The official version is 0.10, but its the preview for 1.0.

Saying 1.0 would be wrong, since we're not at 1.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.