main content container should float to prevent float-clearing content from clearing the nav bar float

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
14 years ago
6 years ago

People

(Reporter: OstGote!, Assigned: David Baron)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch], URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; de-DE; rv:1.8a4) Gecko/20040913 Netscape/7.2
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; de-DE; rv:1.8a4) Gecko/20040913

Visit this URL and see the large gap between the first two headlines
"ftp.mozilla.org mirrors" and "Primary Mirrors".

I see this only with Mozilla trunk builds (like 2004091306). It works as
aspected (without such a large gap) with Firefox 0.10/1.0PR or 0.9.3, Mozilla
1.7.3, Netscape 7.2. So I guess it is not the code but Mozilla.

Reproducible: Always
Steps to Reproduce:

Actual Results:  
Large gap.

Expected Results:  
No large gap, correct layout.

Similiar thing was before for the old version of the frontpage on
website-beta.mozilla.org. So I guess some other pages are still affected.

Comment 1

14 years ago
I believe that this was caused by the fix for bug 148994 and the current display 
is correct. Opera 7.5 displays it just the same as the trunk builds, with 
"Primary mirrors" cleared below the navigation bar.
Yep.  The CSS on this page is just buggy.  Over to the right product.
Assignee: nobody → mozilla.webmaster
Status: UNCONFIRMED → NEW
Component: Layout → webmaster@mozilla.org
Ever confirmed: true
Product: Browser → mozilla.org
QA Contact: core.layout → daniel.bugmail
Version: Trunk → other
ccing myk (author of the buggy CSS)

Comment 4

14 years ago
I'm willing to fix this page.

fantasai, any markup suggestions?
Assignee: mozilla.webmaster → bug
OS: Windows NT → All
QA Contact: daniel.bugmail → fantasai.bugs
Hardware: PC → All

Updated

14 years ago
Summary: Layout problems on www.mozilla.org/mirrors.html, large gap (Mozilla trunk only) → Layout problems on www.mozilla.org/mirrors.html

Comment 5

14 years ago
Created attachment 159094 [details]
/mirrors.html (file, not patch)

This patch follows the style and markup guide more closely and probably gives a
more compact layout that will work. It doesn't need extra styles anymore.

Comment 6

14 years ago
We might want to do something with the ID values, they are not valid at the
moment. Something like 'country.ext'?

Comment 7

14 years ago
Utah should be in TH, not TD.

fantasai, any further suggestions for this document?

Updated

14 years ago
QA Contact: fantasai.bugs → daniel.bugmail
I'm not keen on the wholesale redesign of the structure of the content.  Can we
just fix the issue this bug is addressing, namely the big gap at the top?
I looked into this further and found it's a bug in the new template, not my
code.  My code correctly uses and clears some floats.  The new template, on the
other hand, floats the nav bar to the left but fails to float the main content
container, so any content that clears floats clears the navbar float as well.

The new template should float the main content container so content that clears
floats does so only within the container and doesn't clear the nav bar float.

Morphing the bug accordingly.
Summary: Layout problems on www.mozilla.org/mirrors.html → main content container should float to prevent float-clearing content from clearing the nav bar float
(Assignee)

Updated

14 years ago
Assignee: bug → dbaron
(Assignee)

Comment 10

14 years ago
Created attachment 159147 [details] [diff] [review]
patch

This fixes mirrors.html.  It needs some cross-browser testing.	I might try to
get in a few other changes I want to make before I do said testing.
(Assignee)

Updated

14 years ago
Whiteboard: [patch]
The goal here is to just have mainContent be a new block reflow context, right?
 Wouldn't relatively positioning it with zero offsets have that effect?
(Assignee)

Comment 13

14 years ago
fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Thanks a lot for breaking my part of the website once again within three weeks. 
I really appreciate fixing bugs that other people introduce without telling me :-(

It might be a totally new concept to some people, but there are still parts of
www.mozilla.org, which are well maintained and where people would like to be
informed beforehand, if someone touches code, which might or does break their
markup.

It's a lot of fun, when your hear via the calendar newsgroup that your website
is broken and you have to spend nearly an hour on doctor.mozilla.org to fix the
site immediately :-(((
(Assignee)

Comment 15

14 years ago
This shouldn't have broken anything that wasn't hand-wrapped, and if you're
adding new hand-wrapped pages, you should expect them to break unless I know
about them.

Comment 16

14 years ago
Please reopen, the large gap is back again. Btw. the OSL logo isn't entirely 
inside the sponsors box. I much prefer how this page looks in IE.
Yeah, reopening.  The patch from this bug was backed out because it broke IE
5.5, apparently..
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Simply changing "clear: both;" to "float: right;" in .key-point:after fixed one
issue in update.m.o pages.
(Reporter)

Comment 19

14 years ago
The URL seems now to work. Looks the same in Mozilla 1.8a5 and in FF 1.0. Is it
fixed?

Comment 20

14 years ago
dbaron fixed this 2004-11-10 08:40. "Hack to make the page work. b=259275"
http://rheet.mozilla.org/webtools/bonsai/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=mirrors.html&branch=&root=/cvsroot&subdir=mozilla-org/html&command=DIFF_FRAMESET&rev1=1.143&rev2=1.144
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.