If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

MaxHeap increase on 2004-08-31 due to mozilla.org webpage redesign

RESOLVED WONTFIX

Status

SeaMonkey
General
RESOLVED WONTFIX
13 years ago
11 years ago

People

(Reporter: Robert Kaiser, Assigned: dbaron)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
brad tindoerbox show a massive increase in MaxHeap numbers (from 8.2 MB to 11.9
MB) between 2004-08-31 10:47 and 2004-08-31 13:17 - the checkins in that time
frame are the following:
http://tinderbox.mozilla.org/bonsai/cvsquery.cgi?treeid=default&module=MozillaTinderboxAll&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=1093974420&maxdate=1093983420&cvsroot=%2Fcvsroot

I couldn't come around to look into that more, so I don't know which component
to give it to, I also haven't attached the people that did those checkins yet,
but I thought it should at least be filed ;-)
(Assignee)

Comment 1

13 years ago
The times are the report times, not the pull times.

*** This bug has been marked as a duplicate of 258832 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

13 years ago
Hrm, maybe I shouldn't be so quick.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 3

13 years ago
OK, this does seem real.  The files updated on the server were:

U mozilla/calendar/resources/content/calendarManager.js
U mozilla/layout/base/public/nsHTMLReflowMetrics.h
U mozilla/layout/html/base/src/nsLeafFrame.cpp
U mozilla/layout/html/base/src/nsSpacerFrame.cpp
U mozilla/layout/html/forms/src/nsComboboxControlFrame.cpp
U mozilla/layout/html/forms/src/nsFieldSetFrame.cpp
U mozilla/layout/html/forms/src/nsFileControlFrame.cpp
U mozilla/layout/html/forms/src/nsFormControlFrame.cpp
U mozilla/layout/html/forms/src/nsHTMLButtonControlFrame.cpp
U mozilla/layout/html/forms/src/nsIsIndexFrame.cpp
U mozilla/layout/html/table/src/nsTableOuterFrame.cpp
U mozilla/layout/xul/base/src/nsBoxFrame.cpp
U mozilla/mailnews/extensions/palmsync/src/PalmSyncImp.cpp
U mozilla/mailnews/extensions/palmsync/src/nsAbIPCCard.cpp

Though maybe Brad did something to the machine.
(Assignee)

Comment 4

13 years ago
Though it seems real, since balsa showed an increase, although a much smaller one.
(Assignee)

Comment 5

13 years ago
balsa on SeaMonkey-Ports rose from 7.57MB to 8.25MB between 13:23 and 16:20. 
balsa on Firefox rose from 7.41MB to 7.81MB between 11:10 and 14:31 and from
7.81MB to 8.12MB later, but has been intermittently giving the lower numbers.

And from all the graphs this looks like an increase that happens most of the
time but not all of it.
(Assignee)

Comment 6

13 years ago
I know what this was.  (The inconsistency in the times forces our hand.)

This was when the mozilla.org webpage redesign landed.  It landed on 2004-08-31
at 14:32 PDT (GMT-0700).  And the inconsistency in times is explained by looking
at the times at the end of the run rather than the start.
(Assignee)

Updated

13 years ago
Summary: MaxHeap increase on 2004-08-31 → MaxHeap increase on 2004-08-31 due to mozilla.org webpage redesign
(Assignee)

Updated

13 years ago
Assignee: general → dbaron
Status: REOPENED → NEW
(Assignee)

Comment 7

13 years ago
We might want to switch the pages due to the variation, probably caused by the
JS-loaded image.
Product: Browser → Seamonkey
(Reporter)

Comment 8

11 years ago
I don't think anyone still cares about this.
Status: NEW → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.