Popup blocker still blocks popups when it's switched off; also blocks Flash popups.

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: alex, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Turning the popup blocker off completly causes it to still block popups.

Also, Popups opened from within a Flash site with this actionScript command:

getURL("javascript:window.open('url', 'window', 'options')"); 

as my sample page demonstrates (click the blue button) fails most of the time,
even if you turn off popup blocking or allow the domain.

Reproducible: Always
Steps to Reproduce:
1. Open http://www.intellifolios.com/login/test.html
2. Click the blue button.
3. If the popup opens the first time, close it, and click it again.

Actual Results:  
The popup fails to open.

Expected Results:  
The popup should open.

Comment 1

14 years ago
Your testcase generates the following error:

Error: doWindow is not defined
Source File: javascript:doWindow('http://www.google.com', 300, 300)
Line: 1

It fails to open a window in both IE 5.5 and Firefox 1.0PR
(Reporter)

Comment 2

14 years ago
I apologize, I accidently changed the SWF file.

It's back now, and the bug still exists.

Comment 3

14 years ago
It works for me, was able to open the window about 10-15 times in a row with no
problems on Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913 Firefox/0.10

If you have any extensions installed could you please try disabling them and
retest. Also, when the popups fail to appear does the popup blocked icon appear
in the bottom right of the status bar?
(Reporter)

Comment 4

14 years ago
Sorry about this, guys. Turns out that it's Tabbrowser Extensions which is
causing the problems.

Firefox is awesome!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.