Closed Bug 259305 Opened 18 years ago Closed 16 years ago

thunderbird -remote not working on linux

Categories

(Thunderbird :: General, defect)

x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: s.aura, Assigned: mscott)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: 

Just installed 0.8 and went back to 0.7.3. in 15 minutes. It looked cool
otherwise but the -remote option was not working for me. I use a wrapper to
start Thunderbird so it works with mailto-clicks from Firefox without bringing
profile manager.


Reproducible: Always
Steps to Reproduce:
1. Start Thunderbird 0.8. so you have a running thunderbird window
2. From command line try thunderbird -remote "mailto()" and similar commands


Actual Results:  
Message "Error: No running window found"

Expected Results:  
Bring up a new compose window in the running Thunderbird instance
*** Bug 259345 has been marked as a duplicate of this bug. ***
I am the original submitter and would like to inform that I have found work
arounds by looking little bit more closely to other existing bugs. Here is
summary of what I have found with thunderbird 0.8:
1) /path_to_thunderbird/thunderbird -remote "mailto()" brings the error
2) /path_to_thunderbird/thunderbird -a Thunderbird -remote "mailto()" works
perfectly like it is supposed to
3) /path_to_thunderbird/mozilla-xremote-client -a Thunderbird "mailto()" works
perfectly.

Given 2) and 3) I am now happily using 0.8.
Severity: normal → trivial
*** Bug 259897 has been marked as a duplicate of this bug. ***
Confirming based on dupes, to make the bug easier to find in a default search.
I don't run Linux and so can't really test this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
#1 Doesn't work because of Bug 177996 (I think). #2 and #3 are about the same
and that bug was Bug 247754, which was duped to Bug 244060 (which isn't fixed so
Bug 247754 should actually be reopened). So, I guess this bug should be marked
dupe to Bug 247754.
Severity: trivial → minor
I cannot get it to work with mozilla-thunderbird -a Thunderbird -remote
"mailto(hej@hej)". Tried with the explecit path to mozilla-thunderbird-bin too.

On Debian unstable (AMD64).

I get:
$ mozilla-thunderbird -a Thunderbird -remote "mailto()"
selected locale: en-US
Error: No running window found
on debian, use /usr/lib/mozilla-thunderbird/mozilla-thunderbird-xremote-client
instead of manually trying to use the -remote switch.
*** Bug 263516 has been marked as a duplicate of this bug. ***
thunderbird-remote is working just fine nowadays... (though I'm not sure all of the options mentioned in the comments are still valid)

->wfm (though there may be a duplicate)
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.