Thunderbird 0.8 does not work with -remote commands

RESOLVED DUPLICATE of bug 259305

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 259305
14 years ago
14 years ago

People

(Reporter: Saku Aura, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: 

First apologies if this bug got filed in duplicate, I thought that I filed this
already, but it is not showing up.

I installed 0.8 for Linux (running Mandrake 10 Official). I went back to 0.7.3.
after noticing that the command line remote -option does not work with 0.8 with
my setup. This is needed for a wrapper that is to handle mailto-clicks from
browser without opening the Profiles-dialog if Thunderbird is already running.

Reproducible: Always
Steps to Reproduce:
1. Start Thunderbird and leave it open.
2. from command line give command thunderbird -remote "mailto()" 


Actual Results:  
Error message: "Error: No running window found"


Expected Results:  
Open a new "Compose" window within the existing Thunderbird instance.

Comment 1

14 years ago
I can confirm this on thunderbird 0.8 running RedHat 9.

[kylek@kylepc ~/thunderbird]$ ./thunderbird --version
(null) Thunderbird 0.8, Copyright (c) 2004 mozilla.org
[kylek@kylepc ~/thunderbird]$ ./thunderbird -remote 'ping()'
Error: No running window found
[kylek@kylepc ~/thunderbird]$ ps -aefw | grep -i thunderbird
kylek    19798     1  0 18:32 ?        00:00:00 /bin/sh
/home/kylek/thunderbird/thunderbird
kylek    19811 19798  0 18:32 ?        00:00:00 /bin/sh
/home/kylek/thunderbird/run-mozilla.sh /home/kylek/thunderbird/thunderbird-bin
kylek    19816 19811  0 18:32 ?        00:00:08
/home/kylek/thunderbird/thunderbird-bin

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 259305 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.