trying to "find a node to inspect by clicking on it" in an iframe leads to a crash

RESOLVED FIXED

Status

Other Applications
DOM Inspector
RESOLVED FIXED
14 years ago
11 years ago

People

(Reporter: Clayton Smith, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

trying to "find a node to inspect by clicking on it" in an iframe leads to a crash.

Reproducible: Always
Steps to Reproduce:
1. go to a website with an iframe
2. in the DOM Inspector click on button that has the tooltip "Find a node to
inspect by clicking on it"
3. click within an iframe
Actual Results:  
Browser crash.  It asks if I want to "send an error report"(in windows)

Expected Results:  
go to the node in the Document - DOM Nodes tree structure.

Comment 1

14 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a4) Gecko/20040914

I removed the URL from the URL field, as there is no iframe on that URL:
http://bugzilla.mozilla.org/enter_bug.cgi?product=Browser

can you give an example for a URL where this happens, and description where to
click? What is in your crashing IFRAME, maybe a blocked image?
(Reporter)

Comment 2

14 years ago
Created attachment 159014 [details]
information that is normally submitted to MS
(Reporter)

Comment 3

14 years ago
There was an IFRAME at the URL I had posted earlier
There is also an iframe at this url:
http://www.w3schools.com/tags/tag_iframe.asp
anyway.. I just tested this on another computer that is running the FF 1.0 PR (I
am running FF .9.3) and I experienced no problems on that computer. so... if I
am the only one that can reproduce the problem it's probably not a bug.

Comment 4

14 years ago
I removed http://bugzilla.mozilla.org/enter_bug.cgi?product=Browser as I didn´t
see there any IFRAME, I even used view-source to check.

http://www.w3schools.com/tags/tag_iframe.asp has an IFRAME, and I had no
problems  with that one using DOM-Inspector.

Please give an URL where you experienced the crash, not a random URL having an
IFRAME. Maybe the contents of that IFRAME matters, bug may be seen sometimes
only, when a special ad is displayed.
Is this a problem on trunk?  I suspect that this is long since fixed by bug
246012 on trunk....

Comment 7

14 years ago
resolving wfm

bug 246012 was marked 'fixed-aviary1.0' on 2004-08-09, so that bug is likely to
be in your Firefox rv:1.7) Gecko/20040803 Firefox/0.9.3 from comment #0,
but not in the FF 1.0PR you mentionend working in your comment #3.

feel free to reopen, if you see this bug FF1.0 PR or a current nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
We know what fixed this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
Assignee: dom-inspector → nobody
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.