Closed Bug 259357 Opened 15 years ago Closed 15 years ago

after choosing not to install any icons in the installer, mozilla makes an empty folder in your start menu anyway

Categories

(Firefox :: Installer, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 245392

People

(Reporter: bugzilla, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

after choosing not to install any icons in the installer, mozilla makes an empty
folder in your start menu anyway.

annoying, has done this for the last few versions now.



Reproducible: Always
Steps to Reproduce:
1. run mozilla installer
2. on the icons page deselect all 3 checkboxes
3. complete the installation

Actual Results:  
ff makes an empty folder in start menu/programs

Expected Results:  
it shouldn't do this.




why does it create a folder at all? 
icons should be directly in startmenu/programs - not in a subfolder. 
all MS and adobe apps do this and its far more sensible than cluttering
everything up. 

having a folder for just one icon is insane and just lengthens the time taken to
load it. 
also hides the pretty and recognisable icon until you actually find and open the
"mozilla firefox" subfolder in your startmenu.

i believe (don't quote me on this) that this is against the original win95
usability guidelines for developers.

*** This bug has been marked as a duplicate of 245392 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.