No keyboard shortcut to Page Info

VERIFIED WONTFIX

Status

()

Firefox
Keyboard Navigation
--
minor
VERIFIED WONTFIX
14 years ago
8 years ago

People

(Reporter: Jens Gyldenkærne Clausen, Assigned: Aaron Leventhal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

The shortcut Ctrl-j used to open Page Info. Now it opens the download manager
(formerly Ctrl-y). Ctrl-i - which on Mozilla (not Firefox 0.9.x) opened Page
Info is on Firefox now set to open the Bookmarks sidebar - just as Ctrl-b does.

Judging from the menu, there is no shortcut to open Page Info. Why is that? It
is a vital tool for a web developer - and usefull for many others as well. 




Reproducible: Always
Steps to Reproduce:
1. Try to open Page Info using a keyboard shortcut.




I just noticed that the context menu doesn't include any shortcuts for its
functions (back, forward, reload, etc.)

I believe Opera has a much better approach here - with extensive use of
shortcuts and listing the shortcuts next to the menus also in context menus. A
possibility to edit the shortcuts using either about:config or (better) GUI
would also be a major improvement.
> The shortcut Ctrl-j used to open Page Info. Now it opens the download manager
> (formerly Ctrl-y). Ctrl-i - which on Mozilla (not Firefox 0.9.x) opened Page
> Info is on Firefox now set to open the Bookmarks sidebar - just as Ctrl-b does.

Ctrl-I was always bound to bookmarks for IE key-compatibility.  Just as Ctrl-E
is a secondary keybinding for search.  This is all by design.
 
> Judging from the menu, there is no shortcut to open Page Info. Why is that? It
> is a vital tool for a web developer - and usefull for many others as well. 

The most common use for Page Info is security info, which most users access via
the secure site icon.  Other than that, its a power-userish feature, and we've
prioritized other things for shortcuts.

> I just noticed that the context menu doesn't include any shortcuts for its
> functions (back, forward, reload, etc.)

That's because every major platform UI guide states clearly that this should not
be done.
 
> I believe Opera has a much better approach here - with extensive use of
> shortcuts and listing the shortcuts next to the menus also in context menus. A
> possibility to edit the shortcuts using either about:config or (better) GUI
> would also be a major improvement.

Opera's approach is rather different from what is recommended.  Most HIGs
recommend only having shortcuts for the most common actions.  There's been a
trend in some apps to create reams of shortcuts for every action they can pull
it off for, which isn't necessarily the best course of action.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)

> Ctrl-I was always bound to bookmarks for IE key-compatibility.  Just as Ctrl-E
> is a secondary keybinding for search.  This is all by design.

Fair enough - but couldn't you make it easier to define/redefine your own shortcuts?


> The most common use for Page Info is security info, which most users access via
> the secure site icon.  Other than that, its a power-userish feature, and we've
> prioritized other things for shortcuts.

I can understand that it is important to make the transition form IE to Firefox
as easy as possible - and that the needs of power users may come second. But is
is IMO disappointing when the efforts to make IE=>Firefox-transition easier
results in disimprovements for power users. 

I believe that Mozilla/Firefox' share of power users is much higher than IE -
among other things because these browsers offer so much more than IE6 does - and
it is power users that draw most advantages out of this "extra" that Mozilla and
Firefox offers. So when a new version retracts some of the extra goodies, it is
disappointing.


> That's because every major platform UI guide states clearly that this should not
> be done.

I strongly disagree. I haven't seen the arguments for not including shortcuts
everywhere, so I may have missed some kind of reason - but I find it quite
disturbing if the general recommendation is not to include shortcuts in context
menus. In all the programs I use I try to use the shortest possible way when I
wan't to give a command to the program. This will typically be a shortcut if I
am aware of one, otherwise a right-click using the context menu and only as my
third choice the main menu. This means that I will see the context menu a lot
more than the main menu - and as a consequence I will have much better chance of
leaning shortcuts to menu options used often if the shortcuts are shown besides
the menu options in the context menu.

Again, if this for some reason is considered "too much" for a new user, then put
it in an option ("Show shortcuts in menus YES|NO").


> Opera's approach is rather different from what is recommended.  Most HIGs
> recommend only having shortcuts for the most common actions.  There's been a
> trend in some apps to create reams of shortcuts for every action they can pull
> it off for, which isn't necessarily the best course of action.

Opera's approch is different from Firefox' in two ways - 
A) they have shortcuts for almost anything 
B) they list the shortcuts many places

I'm not sure that A is the "best course of action" in all cases, but I can't see
any problems with B.

Next to tabbed browsing, I think that "find as you type" was the most important
reason I had to skip IE for Mozilla (and later change to Firefox). Using the
keyboard instead of the mouse is vital when you work many hours with a program.
On that count I think that every removal of a shortcut is a disimprovement. Page
Info may not be used much by ordinary users, but it is an important tool for me
as a web developer. 

The absolute best you could do regarding keyboard shortcuts was to implement a
GUI where shortcuts could be defined and redefined. 

Comment 3

14 years ago
*** Bug 260011 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
*** Bug 260019 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
Ctrl + I still brings up Page Info on linux gtk2/xft installer tarball firefox

Comment 6

14 years ago
(In reply to comment #5)
> Ctrl + I still brings up Page Info on linux gtk2/xft installer tarball firefox

On Windows 1.0 pre release CTRL+I opens the bookmarks sidebar!

In the tools menu there is also no short cut displayed beside the "Page Info"
item. In older Firefox versions there was a short cut!

Comment 7

14 years ago
(In reply to comment #6)
> (In reply to comment #5)
> > Ctrl + I still brings up Page Info on linux gtk2/xft installer tarball firefox
> 
> On Windows 1.0 pre release CTRL+I opens the bookmarks sidebar!
> 
> In the tools menu there is also no short cut displayed beside the "Page Info"
> item. In older Firefox versions there was a short cut!

As explained here in this bug (see comment 1), there's no shortcut anymore on
Windows, because ctrl-I opens the bookmarks window to provide compatibility wiht
Internet Explorer. On Linux and Mac OS X, this isn't necessary, so ctrl-I still
opens page Info.
Status: RESOLVED → VERIFIED

Comment 8

14 years ago
to Jo Hermans:

(In reply to comment #7)>

 As explained here in this bug (see comment 1), there's no shortcut anymore on
> Windows, because ctrl-I opens the bookmarks window to provide compatibility wiht
> Internet Explorer. On Linux and Mac OS X, this isn't necessary, so ctrl-I still
> opens page Info.

What the f***... sorry. Why WONTFIX? Do you mean you are not interested in
adding a shortcut for windows firefox again?

But a shortcut is needed in some cases! On popup windows that contain a
full-size java-applet or flash animation and no tool bar, there is no way to
open the "Page Info"-window, if no shortcut is available
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


If you don't want to use CTRL+I, choose any other short cut !!!!

Comment 9

14 years ago
to Jo Hermans:

(In reply to comment #7)>

 As explained here in this bug (see comment 1), there's no shortcut anymore on
> Windows, because ctrl-I opens the bookmarks window to provide compatibility wiht
> Internet Explorer. On Linux and Mac OS X, this isn't necessary, so ctrl-I still
> opens page Info.

What the f***... sorry. Why WONTFIX? Do you mean you are not interested in
adding a shortcut for windows firefox again?

But a shortcut is needed in some cases! On popup windows that contain a
full-size java-applet or flash animation and no tool bar, there is no way to
open the "Page Info"-window, if no shortcut is available
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


If you don't want to use CTRL+I, choose any other short cut !!!!
(Assignee)

Comment 10

14 years ago
This is mostly a big deal to Mac folks, who don't have slower keyboard access to
menu items unless there's an accelerator. On other platforms you can just hit
Alt+V I

Comment 11

14 years ago
(In reply to comment #10)

> Alt+V
 ... is no solution for this problem. On this bugzilla page for example, ALT+V
scrolls just up and focuses the version menu.

Open http://go.icq.com/ and click "If ICQ2Go! does not start - click here"-link.
There is no way to open the Page Info window for this popup window that contains
a java applet!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Comment 12

14 years ago
So a short cut is really needed for some cases !!!
(Assignee)

Comment 13

14 years ago
I hear you, the conflict between acceskeys in content and UI mnenomincs is
really bad.

You can hit Alt separately to get to the menu bar, then hit V then hit I
You can also hit F10 to get to the menu bar.

Comment 14

14 years ago
(In reply to comment #13)

This does not work for this popup, because the java applet is always focused!

But neverthelesse: Think about the fact why the short cut has been removed:
Someone wanted to make life more easy for former IE users, to just jave the same
short cut.

And therefore we make it extremely difficult (or impossible) to open the Page
Info window!!!

Comment 15

14 years ago
I will re-open my own bug now, that as been set as duplicate of this bug....

Comment 16

14 years ago
*** Bug 260019 has been marked as a duplicate of this bug. ***
*** Bug 260019 has been marked as a duplicate of this bug. ***

Comment 18

14 years ago
CTRL+B is displayed as bookmark sidebar short cut. And it does work. Now we have
2 bookmark sidebar short cuts (CTRL+B and CTRL+I). But no short cut for Page Info.

This must have been the idea of an very intelligent guy...

Comment 19

14 years ago
*** Bug 260019 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
I think CTRL+B is not needed anymore for the bookmarks sidebar and could be used
for Page Info.
Incessantly spamming bugs because you disagree is not going to go very far.

There is an extension to rebind keys, I suggest you use it instead of continuing
to be rude and breaking numerous bits of bugzilla etiquette.
> > That's because every major platform UI guide states clearly that this should not
> > be done.
> 
> I strongly disagree. 

Its a fact that the UI guides state that context menus shouldn't show shortcuts
(accesskeys yes, shortcuts, no)

Apple
"Commands with keyboard shortcuts should be noted in the menu bar menu but not
in the contextual menu."

GNOME
"Provide an access key for each item. However, to enhance their spatial
efficiency and readability, do not show keyboard shortcuts in popup menus."

Windows
"In addition, access keys, arrow keys, enter, and ESC keys operate in shortcut
menus the same way they operate in drop-down menus. However, to enhance spatial
efficiency and readability, avoid including shortcut keys in shortcut menus."

Comment 23

14 years ago
Have you ever thought about people who use the mozilla programs on different
platforms? On every Operating system they have a Firefox that is different in
many ways!!!

Just have a look at OpenOffice. They have a program that is very m 	homogeneous
in all platforms! In my oppionion Mozilla should go the same way.

Please keep in mind: People who switch from ie to firefox do so because they
want to have an other browser, not a clone!

Comment 24

14 years ago
to mike connor:

(In reply to comment #21)

> There is an extension to rebind keys, I suggest you use it

if you mean "keyconfig", this extension has no item to assign a shortcut for
Page Info !!!

(Reporter)

Comment 25

14 years ago
(In reply to comment #21)

> There is an extension to rebind keys, I suggest you use it instead of continuing
> to be rude and breaking numerous bits of bugzilla etiquette.

Can you give a name and/or link to this extension? If it enables me to rebind
shortcuts, I will be a happy man again.

For the record -  I have no intention of breaking bugzilla etiquette. I guess
that the comment was aimed at Norbert (comment #20). I share the wish for a
shortcut to page info with Norbert and others, but I strongly disagree with his
use of the bugzilla system.
(Reporter)

Comment 26

14 years ago
(In reply to comment #22)

> Its a fact that the UI guides state that context menus shouldn't show shortcuts
> (accesskeys yes, shortcuts, no)

I don't (and didn't) doubt what UI guides state regarding shortcut visibility. I
do however still disagree with their conclusion.


> However, to enhance spatial efficiency and readability, 

I may have a language problem here (I'm not a native English speaker). I'm not
sure I understand "spatial efficiency" correctly. This is probably not the right
forum to discuss English terms in, but if you can redirect me to an address
where this "spatial efficiency" term is described, I may understand a bit of the
argument for not showing shortcuts in context menus.

Comment 27

14 years ago
(In reply to comment #21)

> Can you give a name and/or link to this extension? If it enables me to rebind
> shortcuts, I will be a happy man again.

http://mozilla.dorando.at/keyconfig.xpi

but as I already said, it cannot add add shortcuts for funktions that have no
shortcut. it looks like it only can change already existing shortcuts.

Comment 28

14 years ago
Please have a look at Bug 261622. I think this would be a better solution for
such problems than mutilating Firefox.

Comment 29

14 years ago
In answer to comment 26, whilst I fear that the polysyllabic expression
"spatial efficiency" is being used to hide sloppy (or maybe only lazy) 
thinking, in the context that it was drawn from; there should be no dispute 
that the proper use of space and spatial cues in HCI design is 
critically important.

See 
http://mjtsai.com/blog/2002/11/26/that_finder_thing
http://developer.gnome.org/projects/gup/ut1_report/customization_tasks.html
http://www106.pair.com/rhp/free-software-ui.html
http://www.joelonsoftware.com/uibook/chapters/fog0000000059.html

I suspect that the thinking is that because the keyboard short cuts are 
(or should be) available for the user to scrutinise on the main menu - it
seems that Cmd-{ for back (which works) is not on the 'Go' menu after
all, ho hum - they are not necessary on the context menu, and are 
actually undesirable because the context of a context menu is to do one 
simple thing on the object under the mouse, (Fitt's Law par excellence)
without distracting the user by trying to teach him or her how to use
the keyboard.

In my opinion this is an example of a principle of user interface design 
which is just outside the top ten (and very hard to perfect) that says 
that when there is more than one reasonable way of doing something, be
wary of offering the user a choice - the effort involved in stopping
in one's tracks to select the better of two reasonable alternatives
will nearly always be greater than using either consistently, even the 
worse.

If you are just starting out in studying UI design you will need to read
at least Tog On Interface http://www.asktog.com/basics/firstPrinciples.html
at one end (mine as it happens) of a spectrum and, say, Mathew Thomas
http://mpt.phrasewise.com/ at the other.

Good luck

(Reporter)

Comment 30

14 years ago
I haven't had time to read all of the references you sent, but I would like to
make a comment on the article from joelonsoftware.com.

He argues that new users gets confused over to many options and advanced users
don't really need/use them anyway. I don't think either of those arguments hold.

Advanced options can (and should be) hidden from the basic UI - making them
invisible for all exept the advanced users.

And regarding the argument that configurations doesn't propagate - making them
more or less useless: Not all expert users use that many computers. And even if
an expert user makes changes to shortcuts, it doesn't nescessarily mean that he
actually changes existing shortcuts - in my own experience it is much more
common to define new shortcuts than it is to alter existing ones. 

I have no problem in adjusting to the default set of shortcuts when I
occasionally use other computers.
(Reporter)

Comment 31

14 years ago
Maybe this is just a dead bug, but anyway.

What was the reason to make the changes in shortcuts for Page Info and
Downloads? Originally I thought that it was an effort to make Firefox more
IE-like, but as Mike Conner stated as early as in comment #1, the changes do not
affect how much Firefox shortcuts resemble IE shortcuts.

Neither Page Info nor Downloads have equivalent IE functions - so there is no
need to make it more equal here. Opera has a download window - which is called
with Ctrl-Alt-T or Ctrl-7 - nothing that resembles Ctrl-y or Ctrl-j.

So why is Ctrl-j a better choice for the download window than Ctrl-y was? And
who decides that an existing shortcut is to be removed?

If there were lack of easy-to-use shortcuts (i.e. Ctrl+<single letter>), I could
understand why the development team might kill a shortcut to a seldom used
function in favor of a shortcut to a function that needed it more. But I can't
see any reason in slaughtering a shortcut just because it is to a "power-userish
feature". 

Finally - where should one go to find a full list of changes for a given version
of Firefox? The release notes only mention changes in headlines - the page 
http://www.squarefree.com/burningedge/releases/0.10.html goes into some detail,
but the changes mentioned in this bug is as far as I can see not mentioned
anywhere else?

The strength of this bugzilla system - where people can supply feedback to
developers and vice versa - is great, but exactly for that reason I get a bit
disappointed when some changes apperently are made without informing anyone
outside the development team.

I still hope for a shortcut to Page Info or (and) a way to define your own
shortcuts.

Comment 32

14 years ago
(In reply to comment #31)
> Maybe this is just a dead bug, but anyway.
It would be nice if it wasn't but I fear that it is.

> So why is Ctrl-j a better choice for the download window than Ctrl-y was?
CTRL+Y is the shortcut for "Redo", that's why CTRL+J 
was set to downloads (from being CTRL+Y)

I, personally would like to see CTRL+I for the page 
info keyboard shortcut, since CTRL+B is already for 
bookmarks (if Comment #18 is right) -- bookmarks doesn't need both.
(Reporter)

Comment 33

14 years ago
(In reply to comment #32)

> CTRL+Y is the shortcut for "Redo", that's why CTRL+J 
> was set to downloads (from being CTRL+Y)

Ah - I had not noticed that there was a new binding to Ctrl-y (the redo function
is only enabled when the undo function has been activated - so just pressing
Ctrl-y to check if there is an action doesn't work).


> I, personally would like to see CTRL+I for the page 
> info keyboard shortcut, since CTRL+B is already for 

Me too - but Ctrl-i is there for IE compatibility, and will propably be hard to
change. I've just noticed that the linux version of Firefox uses Ctrl-i to Page
Info - but here the need to be "like IE" is not important. 

As a web developer, I was very fond of Mozilla's shortcut couple Ctrl-i (Page
Info) and Shift-Ctrl-i (DOM inspector). My use of these two functions are
closely related, and hence it was pleasantly logical that the shortcut keys were
so close.

An option to enable/disable IE key compatibility could still be one way forward.

Comment 34

14 years ago
(In reply to [my own] comment #32)
> I, personally would like to see CTRL+I for the page 
> info keyboard shortcut, since CTRL+B is already for 
> bookmarks ...

ah, the power of extensions:

Pithy 0.2 (Was: For those desiring a page-info hotkey.)
http://forums.mozillazine.org/viewtopic.php?t=135736


I can have it my way, and the WONTFIX can have it theirs!
*** Bug 263188 has been marked as a duplicate of this bug. ***

Comment 36

14 years ago
Created attachment 161276 [details] [diff] [review]
Patch against 1.0PR to assign Ctrl+I to Page Info & Update Help

For those of you who spin your own builds, here's the patch I used to assign
Ctrl+I to Page Info (instead of Bookmarks) for 1.0PR.  It also updates the key
bindings in Help to match the new key bindings.  This may be bitrotted, but it
should be easy enough to unbitrot.

Comment 37

14 years ago
> If there were lack of easy-to-use shortcuts (i.e. Ctrl+<single letter>)

On Windows, Firefox has assigned every Ctrl+letter shortcut except Ctrl+Q, which
is traditionally Quit.  I'm not sure about other platforms.

> Finally - where should one go to find a full list of changes for a given version
> of Firefox? The release notes only mention changes in headlines - the page 
> http://www.squarefree.com/burningedge/releases/0.10.html goes into some detail,
> but the changes mentioned in this bug is as far as I can see not mentioned
> anywhere else?

http://www.squarefree.com/burningedge/ has more detail than
http://www.squarefree.com/burningedge/releases/.  Bonsai has even more detail.
If you want to see the bugs in Bugzilla, you could query Bugzilla for bugs
marked as FIXED during the release cycle or use the collect buglinks bookmarklet
on Bonsai.

> On popup windows that contain a full-size java-applet or flash animation and 
> no tool bar, there is no way to open the "Page Info"-window

The same argument can be made for adding a keyboard shortcut or context menu
item for dozens of features.  The best solution is not to create keyboard
shortcuts and context menu items for everything, but to ensure that you can
always access the normal menus (bug 69099).

Comment 38

14 years ago
i would like to insist on having a shortcut on windows
for popping the PAGE INFO window..
as mentioned in some previous comments if a popup window
has no menubar and the content is 100% flash or java
it is downright impossible to get the PAGE INFO for it..

it was mentioned that all ctrl+<letter> shortcuts were taken
but humm.. is it possible to use like shift-ctrl-i ?

thanks and best of luck for the remaining days.. :D
(Reporter)

Comment 39

14 years ago
(In reply to comment #38)
> it was mentioned that all ctrl+<letter> shortcuts were taken
> but humm.. is it possible to use like shift-ctrl-i ?

Shift-Ctrl-i is bound to DOM Inspector - a real "poweruser feature" (more than
Page Info). I would however not recommend that the shortcut shift-ctrl-i should
be moved to Page Info - for Web Developers the DOM Inspector is more important
than the Page Info dialog.

But since both Page Info and DOM Inspector are relevant tools in web developing,
the "old" solution with ctrl-i to Page Info and ctrl-shift-i to DOM Inspector
was very nice.

/Jens

Comment 40

13 years ago
It really looks like most people would like to have page-info hotkey back
instead of 2 for the bookmarks-sidebar. But seems to not interest the
developers... :-(
(Assignee)

Comment 41

13 years ago
Just hit Alt, release, then V I
Or F10 V I

Comment 42

13 years ago
That's not a short cut.

Comment 43

13 years ago
(In reply to comment #41)
> Just hit Alt, release, then V I
> Or F10 V I

this doesn't work if you are viewing a flash file (.swf) as opposed to an html
file with embedded flash.

The extension I mention in Comment #34 does work, however.

> ah, the power of extensions:
> 
> Pithy 0.2 ...
> http://forums.mozillazine.org/viewtopic.php?t=135736
> 
> 
> I can have it my way, and the WONTFIXers can have it theirs
(In reply to comment #43)
> this doesn't work if you are viewing a flash file (.swf) as opposed to an html
> file with embedded flash.

If keyboard shortcuts don't work, how would Ctrl+I work?

Comment 45

13 years ago
as specified in comment #38:

> as mentioned in some previous comments if a popup window
> has no menubar and the content is 100% flash or java
> it is downright impossible to get the PAGE INFO for it..

you cannot use ALT-T + I as the menubars are not there in such a popup
but a keyboard shortcut would work..
*** Bug 322669 has been marked as a duplicate of this bug. ***

Updated

10 years ago
Duplicate of this bug: 431658
Duplicate of this bug: 580584
You need to log in before you can comment on or make changes to this bug.