Arabic text doesn't appear as it should. Open same page using IE and compare.

RESOLVED DUPLICATE of bug 199853

Status

()

--
major
RESOLVED DUPLICATE of bug 199853
14 years ago
14 years ago

People

(Reporter: firas, Unassigned)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

The Arabic text appears broken and misaligned. Please compare the same page:
www.my-identity.biz both in IE and FF and you will see the difference.

Reproducible: Always
Steps to Reproduce:
1. Type www.my-identity.biz into the URL bar
2. Observe the page
3. Now observe it in IE

Actual Results:  
Got disappointed in Firefox, though I have to admit it is much faster than IE.

Expected Results:  
presented what IE presents.

Updated

14 years ago
Assignee: bugs → nobody
Component: Web Site → Layout
Product: Firefox → Browser
QA Contact: core.layout
Version: unspecified → 1.7 Branch
The only difference that I can see between FF and IE is that IE is using
kashidas to justify lines and FF is not.

If this is what you mean, then the bug is a duplicate of bug 185600. If you are
seeing another problem, please explain more clearly what it is.
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
Dear Simon,
Thank you for your post. I visited bug 185600. I tried out the attachement and 
it seemed to work fine unlike the webpage attached here. I am no expert in 
this field and don't know what kashida's are to be honest. I recently moved to 
FF as I find it faster to work with than IE. All Arabic pages I have visited 
so far work fine except for the one attached here. What I see on my page is 
that the letters are not aligned vertically to the same base. And thus the 
text looks horrible and difficult to read.
Can you attach a screenshot?
(Reporter)

Comment 4

14 years ago
Created attachment 159179 [details]
Screen shot depicting problem

Please note how the vertical alignment of the letters is offset from the
baseline.
(Reporter)

Comment 5

14 years ago
Created attachment 159180 [details]
screenshot from IE for comparison

IE screenshot for comparison
Do you have the font "Arabic Transparent" (which the page specifies) on your
system? I do have the font and I don't see the bug.
(Reporter)

Comment 7

14 years ago
I do have the font and am truly puzzled with the problem as it only occurs 
with this website and as it seems now on my laptop only! I can not pinpoint 
the problem, but will try installing FF on a Virtual PC to see if things work 
out better there.

Comment 8

14 years ago
 

*** This bug has been marked as a duplicate of 199853 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.