Loss of focus on link in new tab

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Bill Carlson, Unassigned)

Tracking

({qawanted})

1.7 Branch
x86
Linux
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913

I've been having focus problems for some time, the current page just loses it.
Clicking on the page regains focus, so it's more an annoyance than anything.

At any rate, I was finally able to get a reproducible instance:
From http://www.gentoo.org/news/en/gwn/20040906-newsletter.xml, middle click
(setup as open in new tab) the "Emerge messages" link under heading "The other
emerge.log". Focus is lost.

Again, I've seen other instances, but nothing I could nail down. Usually it
involves closing a tab via hotkey, the next tab displayed doesn't get focus.
I've been unable to reproduce that.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Updated

14 years ago
Version: Trunk → 1.7 Branch
I can see the bug, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040913
Firefox/0.9.1+
It doesn't happen when I turn javascript off.
There could be already a bug which is the same as this bug. I haven't looked.
If this isn't a duplicate, this bug needs a simple testcase. 
Narrowing down which JS causes the problem would be good.
Keywords: qawanted

Comment 3

14 years ago
confirmed - Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913
Firefox/0.10

I see this all the time when opening mulitple tabs while searching for
something.  I never attributed this to JS, I always thought it was because the
current window wasent complete when I middle clicked a link to open a new tab in
the background.  

When the new background tab finishes, it steals the focus from the forground
tab.  I usually hit CTRL-L and then TAB to allow me to page up and down with the
keyboard again.  The mouse scroll wheel does not seem to be affected though.

I'll try to find a better test case for my situation.

Comment 4

14 years ago
*** Bug 266092 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
Sounds like dup of bug 200950

Comment 6

14 years ago
Another candidate for dupping is bug 124750
(Reporter)

Comment 7

14 years ago
This bug is the opposite of both of those, they involve opening a new tab which
affects the old tab.

What I see happening is the opposite, say I load up 10 tabs worth of pages and
start reading, closing tabs as I go (note this means all the pages would be
loaded and rendered, reading may take 30 seconds per page). Sometimes, but not
always, closing a tab results in the lose of focus to the next tab up, ie
PGUP/PGDOWN doesn't work (non frame pages). Not the same as 200950 or 124750.

I will try to get a good test case.
Product: Browser → Seamonkey

Comment 8

13 years ago
This worksforme with linux trunk 2005032002.
if I have Mozilla select new tabs as they're opened, the newly opened tab (the
other emergy.log) has focus in the top frame).  If I have the pref off, focus
stays on the link I middle-clicked on.
Yes, seems to work for me now, too.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041217

Specifically with "Load links in background" on, the original test case works
for me as well.
You need to log in before you can comment on or make changes to this bug.