Set to default browser fails to assign text to the (Default) refistry key for the FirefoxHTML tag

RESOLVED DUPLICATE of bug 305040

Status

()

RESOLVED DUPLICATE of bug 305040
14 years ago
13 years ago

People

(Reporter: odapple, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

When setting Firefox to be the default browser, a new registry tag,
"FirefoxHTML", is created in HKEY_CLASSES_ROOT, along with sub-tags
"DefaultIcon" and "shell".  However, no text is assigned to the "(Default)" key
for the "FirefoxHTML" tag.  This prevents the "FirefoxHTML" file type from
appearing in the "File Types" dialogues, which means that "regedit" is only way
to assign other right-click "options" (such as edit or print) to the file type.

Reproducible: Always
Steps to Reproduce:
1. Install Firefox.
2. Use the Firefox Options dialog to set Firefox to be the default browser.
3. Use "regedit" to examine "HKEY_CLASSES_ROOT\FirefoxHTML"
4. Set "(Default)" to "Firefox HTML Document"
5. Notice that "Firefox HTML Document" now appears in the "File Types" dialog
(Reporter)

Comment 1

14 years ago
I erred in my registry teminology.  "FirefoxHTML" is a registry "key" and
"(Default)" is a text "value" for this "key".

Comment 2

14 years ago
At work I run Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041107 
on a Windows 98SE machine.

On my work computer, Firefox always comes up when I click a HTM file because
 I chose it to "open" HTM file types in folder options.
Yesterday I went in firefox options and saw Firefox was not set as my default
browser.
So I made firefox my default browser.
After that I see my "edit with GVIM" right click selection is gone.
So I went looking for folder options file types HTM and could not find it on the
list.
Next I tried to create a new HTM extension.
Windows told me the HTM extension already existed as "FirefoxHTML".
But "FirefoxHTML" does not appear on the folder options file types list,
so I cannot edit it to add "edit with GVIM" capability.

A bug search for "folder options file types FirefoxHTML" returns 200 hits.
This looks like Bugzilla Bug 259376.
Following odapple's instructions, I got FirefoxHTML onto the file types list
and added the "edit" capability that I wanted.
Thanks, odapple !
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 4

13 years ago
I do not encounter this problem on my computers since I have already installed
Firefox, made it my default browser, and modified the registry to fix the
problem.  However, in August I installed the then current version of Firefox on
her WinXP system and the problem was still present.  

It should be easy to fix this problem.  When the code that makes Firefox the
default browser creates the registry key "HKEY_CLASSES_ROOT\FirefoxHTML" it
should set the "(Default)" value for this new key to a resonable string e.g.
"Firefox HTML Document".

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 305040 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.