Auto insertion of a Signature for other identities when replying to mail does not follow prefs

RESOLVED DUPLICATE of bug 259034

Status

--
minor
RESOLVED DUPLICATE of bug 259034
15 years ago
14 years ago

People

(Reporter: brendan.bank, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: Thunderbird 0.7.3 & Thunderbird 0.8

If you have multiple identies of under one account and you have an different 
signature for each identity when you select "Start my reply above the quote" in 
the "Account Settings" dialog window option "Automatically quote the original 
message when replying". The signature is put on the end of the quote instead of 
before the quote.

Reproducible: Always
Steps to Reproduce:
1. configure an second identity in the "Account Settings" main tab by clicking 
on "Manage Identities..." and add an identity. Add an signature for each 
identity. by selecting "Attach this signature:" in the "Identity settings" 
window.
2. Configure "Start my reply above the quote" in the "Account Settings" dialog 
window option "Automatically quote the original message when replying"
3. Reply to a message and select a differt identity from the default.
3. The signature will be put below the quote instead of before.

Actual Results:  
The quote is put after the quoted message instead of below.

Expected Results:  
The quote is should have been put before the quoted message.

none.

Comment 1

15 years ago
'reply_on_top' is, like 'compose_html', an identity-specific preference.
There is no UI for setting these prefs within an identity, you have to tweak the 
prefs.js file. (ref bug 235762)

Comment 2

14 years ago
As noted at the dupe, the setting for reply_on_top now seems to be inherited 
when a new identity is created.

*** This bug has been marked as a duplicate of 259034 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.