Closed Bug 259394 Opened 15 years ago Closed 15 years ago

Firefox doesn't add quick launch icons to all user's accounts

Categories

(Firefox :: Installer, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 256566

People

(Reporter: sbporter, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

After installing Firefox in an admin account, with add firefox icon to quick
launch checked, then logging into a limited account, firefox appears on the
desktop and start menu but not in the quick launch bar.

Reproducible: Always
Steps to Reproduce:
1.install firefox with quick launch icon checked
2.log in to a limited account

Actual Results:  
There isn't a quick launch icon in the limited account.

Expected Results:  
adde firefox to all user's quick launch.
Could be dependent on bug 245392.
Depends on: 245392
Depends to bug 256566?
(Or is duplicate?)
I don't think that installing it for one user should put icons in all the other
user's accounts. I've never heard of any other installers doing that for the
quick launch bar. Some programs do however put themselves in the common start
menu folder.

This is probably WONTFIX.

*** This bug has been marked as a duplicate of 256566 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
No longer depends on: 245392
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
The bug 256566 ask for a choice Install for:
  [ ] Current User
  [x] All Users (need administrator rights)

This bog does not. This bug asks that the current behavior (which is "all users") should be consistent: dektop icon, start menu entry, Quick Launch icon should all be "all users", not part this, part that.


After a quick look (on windows 2000 SP4) I found that Windows does not support common quick launch icons.

Firefox should either :
 - add a note in the install wizard to the Quick Launch icon option, like "Create icons for Firefox / In Quick Launch bar (this user only)*"

or

 - create it for all (most be done with a trick)

* - maybe the current users name should be mentioned, to be on the clear side

Also I see the inconsistent usage of the word "my" :

Create icons for Firefox :
 - On my Desktop
 - In my Start Menu Programs folder
 - In my Quick Launch bar

In two cases it really means "all users" while once it is really "mine".

To conclude, I recommend to un-duplicate this bug.
You need to log in before you can comment on or make changes to this bug.