If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox is sending the incorrect user-agent

VERIFIED DUPLICATE of bug 259397

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 259397
13 years ago
13 years ago

People

(Reporter: Roy Wellington, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913 Firefox/0.10

Firefox sends "Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913
Firefox/0.10" as it's user-agent. This is for the 1.0 Preview Release of
Firefox. Previous versions sent things such as 0.8 and 0.9, and which was their
respective version number. However, the 1.0 release sends 0.1 which I believe is
a typo.

Reproducible: Always
Steps to Reproduce:
1. On the menu bar, hit Help --> About Mozilla Firefox
2. Look at the bottom two lines. They read '...Firefox/0.10'
3. You can also create/view a web page that displays your user-agent.

Actual Results:  
I was told that "Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913
Firefox/0.10" is what Firefox sends as a user-agent.

Expected Results:  
Sent "Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913 Firefox/1.0" (or
1.00, whichever. I personally think 1.0 looks better.) as the user-agent.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 259397 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.