Closed Bug 25941 Opened 20 years ago Closed 20 years ago

spellchecker doesn't launch

Categories

(Core :: DOM: Editor, defect, P1)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: sujay, Assigned: dougt)

Details

(Whiteboard: fix in hand. waiting code review.)

using 1/31 build on all platforms

1) launch browser
2) launch editor
3) type some text
4) click on spellcheck button..

it doesn't come up. In windows console I get:

Check spelling starting...
*************************************************
nsNativeComponentLoader:GetFactory<C:PROGRAM
Files\NETSCAPE\SEAMONKEY\components\spellchecker.dll Load Failed with error:
<unknown; can't get error from NSPR>
***************************************************
Exception error from Spell Checker
m14
Target Milestone: M14
The problem is that the registry does not take note that the spellchecker lives
in a subdirectory. Autoregistration finds dlls in subdirectories, but if you
rerun the application after autoreg, the same problem noted above happens.

Assigning to dp.
Assignee: kin → dp
Ccing dougt he may be fixing this. If you are, could you take the bug away from 
me. I wont get to this before tomorrrow.
Keywords: beta1
Status: NEW → ASSIGNED
Scott, this needs to get fixed soon.
Assignee: dp → scc
Status: ASSIGNED → NEW
Priority: P3 → P1
Status: NEW → ASSIGNED
This is mine.  
Assignee: scc → dougt
Status: ASSIGNED → NEW
Whiteboard: fix in hand. waiting code review.
fix checked in.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
verified in 2/1 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.