Yahoo.com Briefcase upload page scroll bars don't work

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: jjramsey_6x9eq42, Unassigned)

Tracking

({platform-parity})

Trunk
PowerPC
Mac OS X
platform-parity

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10

On Linux, I have been able to upload files to Yahoo! Briefcase using Mozilla,
yet it doesn't work on OS X, neither with Mozilla nor Firefox. It does work,
however, with Internet Explorer and Opera.


Reproducible: Always
Steps to Reproduce:
1. Log in to Yahoo! Briefcase (requires a Yahoo! account)
2. Click the "Add File" link. You should see fields where one can enter file
names, etc. The Web interface is pretty self-explanatory.
3. Try to scroll down, so that you can click on the "Upload" button. In Firefox,
the scrollbar is there but doesn't work, while in Mozilla, the scrollbar is
there momentarily, but disappears.




I'm running Mac OS X 10.3, Panther.
Keywords: pp, qawanted

Comment 1

14 years ago
The page is a weird frameset with dhtml layer effects for unknown reasons,
considering it should be just a simple upload form. For comparison, the
Geocities upload page is vanilla html.

Firefox 1.0PR OSX 10.3.5, the scroll bar does not work, and sometimes
disappears. However, I was able to scroll the page intermittently with my mouse
wheel.

The actual form submission works properly, fired by whatever means (upload
button, enter in a text field, javascript submit).

Guessing -> XP: GUI
Assignee: general → guifeatures
Blocks: 121228
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps: GUI Features
Ever confirmed: true
QA Contact: general
Summary: Cannot upload to Yahoo! Briefcase on OS X → Yahoo.com Briefcase upload page scroll bars don't work
Product: Core → Mozilla Application Suite

Comment 2

14 years ago
This should actually probably be somewhere in Core, but we need more information

First, is this still a problem with a more recent build (nightly FF build or
1.8b of Suite)?
Second, can you save the page that doesn't work and attach it here?  We need a
testcase to identify the problem.

re-dumping in General
Assignee: guifeatures → general
Component: XP Apps: GUI Features → General
QA Contact: general
(Reporter)

Comment 3

14 years ago
Created attachment 182405 [details]
Saved web page that demonstrates scroll bars not working

I've attached some files that should be a decent test case.

Comment 4

14 years ago
ok, I think I see what you're seeing with Mozilla 1.7.7, but it seems to work on
current trunk (2005050602).  Can you try scrolling while being careful not to
move your mouse pointer off the scrollbar?  If my mouse drifts into the page or
out of the window, the scrolling stops.

If that's what you're seeing, can you try a trunk build to see if more recent
builds are also working for you?
(Reporter)

Comment 5

14 years ago
"Can you try scrolling while being careful not to move your mouse pointer off
the scrollbar?  If my mouse drifts into the page or out of the window, the
scrolling stops."

That isn't quite what I'm seeing. Originally, the scrollbar is visible, but
clicking on it doesn't cause it to scroll, and I can't drag the "moving" part of
the scrollbar. Drifting the mouse away from the scrollbar is not sufficient to
make it disappear. Rather, I have to click in the window to lose the scrollbar.

Comment 6

14 years ago
ok, I'm not seeing that on linux.  perhaps a mac thing
(Reporter)

Comment 7

14 years ago
"ok, I'm not seeing that on linux.  perhaps a mac thing"

Definitely a Mac thing, as pointed out in the *original* bug report. I never saw
a problem on Linux.

Comment 8

14 years ago
With the testcase I see the issue on Seamonkey 1.7.7 and Firefox 1.03 (mac os
10.3.9). However, this has been fixed on the trunk (quite recently, since I see
the issue with a one month old FF trunk build) - I can't repro the problem with
current Seamonkey and Firefox trunk builds. Resolving as wfm. J. J. Ramsey,
please reopen if you still see the issue with a recent Firefox/Seamonkey trunk
build.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

14 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.