If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The RSS icon should allow me to subscribe with the RSS via my preferred RSS reader

VERIFIED DUPLICATE of bug 325085

Status

()

Firefox
RSS Discovery and Preview
--
enhancement
VERIFIED DUPLICATE of bug 325085
13 years ago
8 years ago

People

(Reporter: Trejkaz (pen name), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

It feels like a ripoff that Mozilla 1.0PR1 and Thunderbird 0.8 came out at about
the same time, and both got RSS integration, but didn't get integrated together.

It would be great if clicking on the RSS button in the bottom right corner of a
web page resulted in the ability to send the RSS to Thunderbird, just like
clicking on a news: URL results in going to Thunderbird.


Reproducible: Always
Steps to Reproduce:

Comment 1

13 years ago
This is similar to bug #251409. I think I prefer the solution suggested here to
the other one.
(Reporter)

Comment 2

13 years ago
Actually I was probably too presumptuous as well.  What we should actually do is
pass the RSS to the default RSS handler application.  Thunderbird should
register itself as an RSS handler application, and other applications should be
able to do the same.  That way, RSS from Firefox can be fed into SharpReader,
Thunderbird, or whatever the user wants.
(Reporter)

Updated

13 years ago
Summary: The RSS icon should allow me to subscribe with the RSS via Thunderbird → The RSS icon should allow me to subscribe with the RSS via my preferred RSS reader

Comment 3

13 years ago
As someone who prefers to view my RSS feeds in Thunderbird, I would appreciate
it if at the very least there was an option to copy the feed's URL to the
clipboard on the menu that comes up when you click the RSS icon.
I think the minimal and at the same time most flexible solution would be to add
a right-click context menu on the RSS feed symbol that allows pasting the URL to
the clipboard. This lets the user copy the URL to whatever reader applications
he/she wants, including thunderbird. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

13 years ago
(In reply to comment #4)
> I think the minimal and at the same time most flexible solution would be to add
> a right-click context menu on the RSS feed symbol that allows pasting the URL to
> the clipboard. This lets the user copy the URL to whatever reader applications
> he/she wants, including thunderbird. 

I agree. It doesn't even have to be right-click, left click would be fine since
it brings up a menu anyway.
Assignee: firefox → nobody
Component: General → RSS Discovery and Preview
QA Contact: general → nobody

Comment 6

12 years ago
(In reply to comment #4)

Allowing for viewing or copying the URL of the RSS feed would be a great solution, especially for users who read RSS feeds using an online aggregator service.  One of the most annoying things about RSS for some sites is actually locating the URL of the feed.  Most users are not going to be able to view page source to find an RSS URL.

Comment 7

12 years ago
*** Bug 322637 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
I definitely think Firefox should have native handling for other feed readers. I rather like Live Bookmarks, but their usefulness is limited.

Personally, I like the functionality of the "LiveLines" extension. [http://heygom.com/extensions/categories/livelines/].

It allows the feed icon to be used for the following:

1. Live Bookmarks
2. External Feed Reader
3. Feed Reader Firefox Extension (such as Sage)
4. Feed Reading Webservice (Rojo, Bloglines)

Whilst merging it into Firefox as-is wouldn't be suitable (the LiveLines UI isn't of the same standard as the rest of Firefox), the functionality could be integrated and give "Feeds" a dedicated pane in the Firefox PrefWindow. (Also, the configuration for LiveLines webservices is somewhat complex for casual users and needs to be more accessible. See below).

What I'd suggest is that Firefox offer a new preferences pane for Feeds, offering the following:

+----------------------------------------------------+
| (x) Subscribe to feeds using <System Default>*     |
|                                                    |
| ( ) Subscribe to feeds using Live Bookmarks        |
|                                                    |
| ( ) Subscribe to feeds using | Bloglines |^|**     |
|                                                    |
+----------------------------------------------------+

* - This should be the default option when a system default feed reader is detected. I guess that's OS dependent but I have no idea how it would work. <System Default> should obviously be replaced with the name of the application.

** - Rather than manually define Feed-reader web services (as in LiveLines), it would be neat to have a mechanism for the services to add themselves - akin to the installation of search engines elsewhere in the UI.

It could be done using a similar mechanism: A simple text file describes the service and defines the URL used to subscribe to feeds. Bloglines, Rojo et al can then offer an "Install into Firefox" button to automatically configure Firefox by downloading the config file. Having confirmed the change, the user's default feed icon action is then set.

I'd suggest that making the three choices (system default, live bookmark and webservice) exclusive options, rather than allowing multiple, simultaneous handling actions (that sounds confusing and useless to the majority). Instead, add a context menu to the Feed icon for making a non-default choice when needed. 

So I might have my default action as "Subscribe using Rojo", but if I want to add a Live Bookmark instead I could right click the feed icon and still choose "Add as Live Bookmark". "Copy Feed URL to Clipboard" could also appear on the context menu, since I can see it would be useful for when web services failed to offer an automatic config for Firefox.

Finally, you'll note that I left off handling feeds being added to a Firefox extension from this prefpane. I'm of the view that the extension itself, when installed, should take responsibility for hijacking the feed icon.

What do you think?

Comment 9

12 years ago
I don't think this should be set in the preferences, IMO it's best to pop up a menu on the RSS Icon which looks like this:

[RSS] -+- News Feed (Atom)
       +- Comments Feed -+- Subscribe using Firefox
       +- ...            +- Subscribe using System default RSS Reader
                         +- Subscribe using (Webservice)
                         +- Copy Link Location
                         +- ...

Or even better: pop up the Menu, which also appears on hyperlinks (extended to hold the items described above) - so you can choose to subscribe to the feed by using Firefox' RSS Icon or the "old" Feed-Links provided by the Website. Maybe Firefox should also accept the Feeds and ask the user if he wants to Subscribe the feed, download the file or view the content as XML or in a nice Safari-ish way.

Comment 10

12 years ago
Created attachment 215853 [details]
RSS icon context menu mock-up

I agree that users are pretty much locked in with the current way of Firefox handling RSS feeds.

If I want to subscribe to a RSS feed, I usually press Strg+U and look into the surce code in order to find the feed <link rel="alternate"...> URLs. Then I copy them and paste them into firefox. That's dumb!

May I suggest a simple solution? Since there already is a context menu when I click on an RSS icon (at least when there are multiple feeds to subscribe to, e.g. RSS and Atom) I could imagine having a "Copy linkt to 'Feed Title'" option for each feed.

For clarification, I attached a PNG that illustrates what I mean. The screenshot was in german language, but I guess you get the point.

Comment 11

12 years ago
I just noticed that the RSS icon doesn't appear in Firefox 1.5.0.1 DE. Is that a bug? Can't find it in bugzila.

Use http://www.heise.de/ to test. The page has two feeds linked.
Fixed/being fixed by bug 325085/bug 333751/etc.

*** This bug has been marked as a duplicate of 325085 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Verified Duplicate.
Status: RESOLVED → VERIFIED
Resetting QA contact to the default.
QA Contact: nobody → rss.preview
You need to log in before you can comment on or make changes to this bug.