What we have to do to upgrade to Pro5

RESOLVED FIXED in M14

Status

P1
major
RESOLVED FIXED
19 years ago
15 years ago

People

(Reporter: scc-obsolete, Assigned: scc-obsolete)

Tracking

Trunk
PowerPC
All

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
We need to adjust the access paths on each of the following projects.

I built this list with a search in MPW:

  Files -f -o -r -s -t MMPr Akron:Mozilla:Source:mozilla:mozilla: *
   | Search -q .mcp *
   | Search -r -q IDL.mcp

Then I divided the list up among the volunteers such that no directory was split 
between two people.  Here's what needs to be done: for each target in each of 
your projects, if any access path leads _into_ the MacOS Support folder, make it 
lead _to_ the MacOS Support folder (and eliminated duplicates).  Simon mentioned 
another change that needed to be made ... Simon?



brade

:mozilla:build:mac:CustomLib:CustomLib.mcp
:mozilla:build:mac:test:test.mcp
:mozilla:build:mac:test:test2.mcp
:mozilla:build:mac:test:test3.mcp
:mozilla:build:mac:test:test4.mcp
:mozilla:caps:macbuild:Caps.mcp
:mozilla:db:mork:macbuild:mork.mcp
:mozilla:dbm:macbuild:DBM.mcp
:mozilla:dom:macbuild:dom.mcp
:mozilla:dom:src:jsurl:macbuild:JSUrl.mcp
:mozilla:dom:src:jsurl:macbuild:JSUrlDL.mcp
:mozilla:dom:tools:macbuild:IdlCompiler.mcp
:mozilla:editor:macbuild:editor.mcp
:mozilla:editor:txmgr:macbuild:txmgr.mcp
:mozilla:editor:txmgr:tests:macbuild:txmgrTEST.mcp
:mozilla:editor:txtsvc:macbuild:txtsvc.mcp
:mozilla:expat:macbuild:expat.mcp


pinkerton

:mozilla:intl:chardet:macbuild:chardet.mcp
:mozilla:intl:chardet:macbuild:classicChardet.mcp
:mozilla:intl:compatibility:macbuild:intlcmpt.mcp
:mozilla:intl:locale:macbuild:locale.mcp
:mozilla:intl:locale:tests:macbuild:LocaleSelfTest.mcp
:mozilla:intl:locale:tests:macbuild:nsLocaleTest.mcp
:mozilla:intl:lwbrk:macbuild:lwbrk.mcp
:mozilla:intl:strres:macbuild:strres.mcp
:mozilla:intl:uconv:macbuild:TestUConv.mcp
:mozilla:intl:uconv:macbuild:uconv.mcp
:mozilla:intl:uconv:macbuild:ucvcn.mcp
:mozilla:intl:uconv:macbuild:ucvibm.mcp
:mozilla:intl:uconv:macbuild:ucvja.mcp
:mozilla:intl:uconv:macbuild:ucvko.mcp
:mozilla:intl:uconv:macbuild:ucvlatin.mcp
:mozilla:intl:uconv:macbuild:ucvtw.mcp
:mozilla:intl:uconv:macbuild:ucvtw2.mcp
:mozilla:intl:unicharutil:macbuild:unicharutil.mcp
:mozilla:intl:unicharutil:tests:macbuild:UnicharUtilSelfTest.mcp


ducarroz

:mozilla:mailnews:addrbook:macbuild:msgAddrbook.mcp
:mozilla:mailnews:base:macbuild:msgCore.mcp
:mozilla:mailnews:base:util:macbuild:msgUtil.mcp
:mozilla:mailnews:compose:macbuild:msgCompose.mcp
:mozilla:mailnews:db:macbuild:msgDB.mcp
:mozilla:mailnews:db:mork:macbuild:mork.mcp
:mozilla:mailnews:imap:macbuild:msgimap.mcp
:mozilla:mailnews:import:eudora:macbuild:msgImportEudora.mcp
:mozilla:mailnews:import:macbuild:msgImport.mcp
:mozilla:mailnews:import:text:macbuild:msgImportText.mcp
:mozilla:mailnews:local:macbuild:msglocal.mcp
:mozilla:mailnews:mime:cthandlers:calendar:macbuild:calendar.mcp
:mozilla:mailnews:mime:cthandlers:signstub:macbuild:signed.mcp
:mozilla:mailnews:mime:cthandlers:smimestub:macbuild:smime.mcp
:mozilla:mailnews:mime:cthandlers:vcard:macbuild:vcard.mcp
:mozilla:mailnews:mime:emitters:macbuild:mimeEmitter.mcp
:mozilla:mailnews:mime:macbuild:mime.mcp
:mozilla:mailnews:news:macbuild:msgnews.mcp


saari

:mozilla:gfx:macbuild:gfx.mcp
:mozilla:gfx:tests:coverage:macbuild:converage.mcp
:mozilla:htmlparser:macbuild:htmlparser.mcp
:mozilla:jpeg:macbuild:JPEG.mcp
:mozilla:js:macbuild:JavaScript.mcp
:mozilla:js:macbuild:JSLoader.mcp
:mozilla:js:macbuild:LiveConnect.mcp
:mozilla:js:macbuild:LiveConnectClasses.mcp
:mozilla:js:macbuild:TestXPC.mcp
:mozilla:js:macbuild:XPConnect.mcp
:mozilla:js:src:liveconnect:macbuild:LiveConnect.mcp
:mozilla:js:src:liveconnect:macbuild:LiveConnectShell.mcp
:mozilla:js:src:macbuild:JSRef.mcp
:mozilla:layout:macbuild:layout.mcp
':mozilla:lib:mac:embedding:powerplant:PowerPlant Appearance.mcp'
:mozilla:lib:mac:InterfaceLib:Interface.mcp
:mozilla:lib:mac:MacMemoryAllocator:MemAllocator.mcp
:mozilla:lib:mac:MacMemoryAllocator:test:MemoryTest.mcp
:mozilla:lib:mac:MoreFiles:build:MoreFilesPPC.mcp
:mozilla:lib:mac:NSRuntime:NSRuntime.mcp
:mozilla:lib:mac:NSStartup:NSStartup.mcp
:mozilla:lib:mac:NSStdLib:NSStdLib.mcp
:mozilla:lib:mac:PowerPlant:PowerPlant.mcp


davidm

:mozilla:extensions:cookie:macbuild:cookie.mcp
:mozilla:extensions:irc:macbuild:irc.mcp
:mozilla:extensions:wallet:editor:macbuild:WalletEditor.mcp
:mozilla:extensions:wallet:macbuild:wallet.mcp
:mozilla:extensions:wallet:macbuild:walletviewers.mcp
:mozilla:gc:boehm:macbuild:gc.mcp
':mozilla:gc:boehm:macbuild:gctest++.mcp'
:mozilla:gc:boehm:macbuild:gctest.mcp
:mozilla:modules:libimg:macbuild:gifdecoder.mcp
:mozilla:modules:libimg:macbuild:jpgdecoder.mcp
:mozilla:modules:libimg:macbuild:libimg.mcp
:mozilla:modules:libimg:macbuild:png.mcp
:mozilla:modules:libimg:macbuild:pngdecoder.mcp
:mozilla:modules:libjar:macbuild:libjar.mcp
:mozilla:modules:libpref:macbuild:libpref.mcp
:mozilla:modules:libreg:macbuild:libreg.mcp
:mozilla:modules:libutil:macbuild:libutil.mcp
:mozilla:modules:oji:macbuild:oji.mcp
:mozilla:modules:plugin:macbuild:plugin.mcp
:mozilla:modules:zlib:macbuild:zlib.mcp


sdagley

:mozilla:netwerk:cache:macbuild:nkcache.mcp
:mozilla:netwerk:macbuild:netwerk.mcp
:mozilla:netwerk:mime:macbuild:mime.mcp
:mozilla:netwerk:protocol:about:macbuild:about.mcp
:mozilla:netwerk:protocol:data:macbuild:data.mcp
:mozilla:netwerk:protocol:file:macbuild:file.mcp
:mozilla:netwerk:protocol:ftp:macbuild:ftp.mcp
:mozilla:netwerk:protocol:http:macbuild:http.mcp
:mozilla:netwerk:protocol:jar:macbuild:jar.mcp
:mozilla:netwerk:protocol:keyword:macbuild:keyword.mcp
:mozilla:netwerk:protocol:res:macbuild:res.mcp
:mozilla:netwerk:protocol:resource:macbuild:resource.mcp
:mozilla:netwerk:streamconv:macbuild:multiMixedConv.mcp
:mozilla:netwerk:streamconv:macbuild:streamconv.mcp
:mozilla:netwerk:util:macbuild:netwerkUtil.mcp
:mozilla:nsprpub:macbuild:NSPR20PPC.mcp
:mozilla:nsprpub:pr:tests:macbuild:NSPR20TestApp.mcp


sfraser

:mozilla:plugin:oji:MRJ:plugin:MRJConsole.mcp
:mozilla:plugin:oji:MRJ:plugin:MRJInABox.mcp
:mozilla:plugin:oji:MRJ:testing:ConsoleApplet:ConsoleApplet.mcp
:mozilla:plugin:oji:MRJ:testing:JSApplet:JSApplet.mcp
:mozilla:plugin:oji:MRJ:testing:SwingApplet:TestApplet.mcp
:mozilla:plugin:oji:MRJ:testing:TrivialApplet:MyApplet.mcp
:mozilla:profile:macbuild:profile.mcp
:mozilla:profile:pref-migrator:macbuild:prefmigrator.mcp
:mozilla:rdf:brprof:build:brprof.mcp
:mozilla:rdf:chrome:build:chrome.mcp
:mozilla:rdf:macbuild:rdf.mcp
:mozilla:rdf:tests:domds:macbuild:DOMDataSource.mcp
:mozilla:sun-java:stubs:macbuild:JavaStubs.mcp
:mozilla:uriloader:macbuild:uriLoader.mcp
:mozilla:view:macbuild:view.mcp
:mozilla:webshell:embed:mac:RaptorShell.mcp
:mozilla:webshell:macbuild:webshell.mcp
:mozilla:webshell:tests:viewer:mac:viewer.mcp
:mozilla:widget:macbuild:widget.mcp
:mozilla:widget:tests:scribble:mac:scribble.mcp
:mozilla:widget:tests:widget:mac:widgettest.mcp


scc

:mozilla:xpcom:macbuild:FilesTest.mcp
:mozilla:xpcom:macbuild:xpcomPPC.mcp
:mozilla:xpcom:proxy:macbuild:proxy.mcp
:mozilla:xpcom:proxy:macbuild:tests.mcp
:mozilla:xpcom:sample:macbuild:Sample.mcp
:mozilla:xpcom:tests:macbuild:COMTest.mcp
:mozilla:xpcom:tests:macbuild:RegFactory.mcp
:mozilla:xpcom:tools:registry:macbuild:RegExport.mcp
:mozilla:xpcom:tools:registry:macbuild:RegXPCOM.mcp
:mozilla:xpcom:typelib:xpidl:macbuild:test:test.mcp
:mozilla:xpcom:typelib:xpt:macbuild:libxpt.mcp
:mozilla:xpcom:typelib:xpt:macbuild:tests.mcp
:mozilla:xpcom:typelib:xpt:macbuild:tools.mcp
:mozilla:xpfe:AppCores:macbuild:AppCores.mcp
:mozilla:xpfe:appshell:macbuild:AppShell.mcp
:mozilla:xpfe:bootstrap:macbuild:apprunner.mcp
:mozilla:xpfe:browser:macbuild:mozBrowser.mcp
:mozilla:xpfe:components:bookmarks:macbuild:Bookmarks.mcp
:mozilla:xpfe:components:directory:Directory.mcp
:mozilla:xpfe:components:find:macbuild:FindComponent.mcp
:mozilla:xpfe:components:history:macbuild:history.mcp
:mozilla:xpfe:components:prefwindow:macbuild:prefwindow.mcp
:mozilla:xpfe:components:regviewer:RegViewer.mcp
:mozilla:xpfe:components:related:macbuild:Related.mcp
:mozilla:xpfe:components:sample:macbuild:sample.mcp
:mozilla:xpfe:components:search:macbuild:Search.mcp
:mozilla:xpfe:components:shistory:macbuild:shistory.mcp
:mozilla:xpfe:components:ucth:macbuild:ucth.mcp
:mozilla:xpfe:components:xfer:macbuild:xfer.mcp
:mozilla:xpfe:macbuild:xpfeviewer.mcp
:mozilla:xpinstall:macbuild:xpinstall.mcp
:mozilla:xpinstall:macbuild:xpistub.mcp
:mozilla:xpinstall:packager:mac:ASEncoder:build:ASEncoder.mcp
:mozilla:xpinstall:wizard:mac:macbuild:CheckboxLDEF.mcp
:mozilla:xpinstall:wizard:mac:macbuild:MIW.mcp
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Priority: P3 → P1
Target Milestone: M14

Comment 1

19 years ago
While scrubbing these projects, note that the following projects have bad user 
paths pointing to non-existent directories (e.g. network), so please fix these 
too:

libpref.mcp
xpinstall.mcp
appshell.mcp
msgnews.mcp
plugin.mcp
mime.mcp
(Assignee)

Comment 2

19 years ago
OK, I checked in my fixes.  Note: the easy way to do this is to keep the access 
paths for the first project you fix open, so you can continually drag and drop 
the "MacOS Support" path to each of the remaining projects.  This will save you a 
lot of time in the `choose file' dialog.

Don't forget to fix the other targets in each project.
I did my part too (mailnews' projects)

Comment 4

19 years ago
netwerk and nsprpub are done

Comment 5

19 years ago
changing component to build-config and adding the build-config qa contact
Component: Browser-General → Build Config
QA Contact: nobody → cyeh
my i18n projects are all done.

Comment 7

19 years ago
I checked in changes to the following projects:
:mozilla:build:mac:test:test2.mcp
:mozilla:build:mac:test:test3.mcp
:mozilla:build:mac:test:test4.mcp
:mozilla:caps:macbuild:Caps.mcp
:mozilla:db:mork:macbuild:mork.mcp
:mozilla:dbm:macbuild:DBM.mcp
:mozilla:dom:macbuild:dom.mcp
:mozilla:dom:src:jsurl:macbuild:JSUrl.mcp
:mozilla:dom:tools:macbuild:IdlCompiler.mcp
:mozilla:editor:macbuild:editor.mcp
:mozilla:editor:txmgr:macbuild:txmgr.mcp
:mozilla:editor:txmgr:tests:macbuild:txmgrTEST.mcp
:mozilla:editor:txtsvc:macbuild:txtsvc.mcp

The following projects did not need changing:
:mozilla:build:mac:CustomLib:CustomLib.mcp
:mozilla:build:mac:test:test.mcp
:mozilla:dom:src:jsurl:macbuild:JSUrlDL.mcp
:mozilla:expat:macbuild:expat.mcp
(Assignee)

Comment 8

19 years ago
So that leaves sfraser, davidm, and saari.  Additionally, according to "Laura 
Bagnall" <lbagnall@juniornet.com> we need to

  >1.  Line 83 of file mozilla:gfx:src:mac:nsDeviceContextSpecMac.h
  >Changed "friend nsDeviceContextMac;" to "friend class nsDeviceContextMac;"

  >2.  rebuild the file NSStdlib.exp according to the directions on page 93
  >of "Targeting_MacOS.pdf".

  >3.  comment out the routine PBXGetVolInfoSync in MoreFilesExtras.c

  >4.  replaced ICGlue-CFM-PPC.lib with InternetConfigLib in widget.mcp
(Assignee)

Comment 9

19 years ago
...and according to Eric Rainey <erainey@SPARMwgbh.org>

  >In addition to Laura's changes, I also had to change the Perl build
  >script function MakeAlias to look for .xpt folders inside a
  >...IDL Data folder which was created by CW, rather than in the regular
  >build folder.
we also use 3 files from powerplant:

PP_Macros.h
PP_Messages.h
PP_Types.h

for things that are probably Viewer specific. I think we can just copy out the 
relevant constants that we use into some header file so we don't need to keep 
requiring powerplant. In fact, that will also make our OSX build setup easier as 
well.
who is going to do this commercial (ns) tree projects?
(Assignee)

Comment 12

19 years ago
*** Bug 2246 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

19 years ago
changing the summary to be a little more inclusive
Summary: Fix Mac access paths before switch to Pro5 → What we have to do to upgrade to Pro5

Comment 14

19 years ago
For Simon, I've changed these projects:
:mozilla:plugin:oji:MRJ:plugin:MRJInABox.mcp
:mozilla:profile:macbuild:profile.mcp
:mozilla:profile:pref-migrator:macbuild:prefmigrator.mcp
:mozilla:rdf:brprof:build:brprof.mcp
:mozilla:rdf:chrome:build:chrome.mcp
:mozilla:rdf:macbuild:rdf.mcp
:mozilla:rdf:tests:domds:macbuild:DOMDataSource.mcp
:mozilla:sun-java:stubs:macbuild:JavaStubs.mcp
:mozilla:uriloader:macbuild:uriLoader.mcp
:mozilla:view:macbuild:view.mcp
:mozilla:webshell:embed:mac:RaptorShell.mcp
:mozilla:webshell:macbuild:webshell.mcp
:mozilla:webshell:tests:viewer:mac:viewer.mcp
:mozilla:widget:macbuild:widget.mcp
:mozilla:widget:tests:scribble:mac:scribble.mcp
:mozilla:widget:tests:widget:mac:widgettest.mcp

These projects didn't need any changes:
:mozilla:plugin:oji:MRJ:plugin:MRJConsole.mcp
:mozilla:plugin:oji:MRJ:testing:ConsoleApplet:ConsoleApplet.mcp
:mozilla:plugin:oji:MRJ:testing:JSApplet:JSApplet.mcp
:mozilla:plugin:oji:MRJ:testing:SwingApplet:TestApplet.mcp
:mozilla:plugin:oji:MRJ:testing:TrivialApplet:MyApplet.mcp

Note: I have not checked in all of these changes at the time I am entering this 
into bugzilla.

Comment 15

19 years ago
nsCommandLineServicesMac.cpp uses PowerPlant for AppleEvents. These two files
are include, UAppleEventsMgr.h, UExtractFromAEDesc.h.
(Assignee)

Comment 16

19 years ago
Note this information that may helpful in moving to the latest version of 
InternetConfig, posted by <alex@dice.net> in

  <news://news.mozilla.org/879ugq$e0h1@secnews.netscape.com>

Comment 17

19 years ago
I'll handle the commercial tree projects because I'm such a nice guy.

Comment 18

19 years ago
In Pro5 Metrowerks also changed the folder name from "Metrowerks Standard
Library" to "MSL". Some projects also include into MSL, perhaps we should also
change these?
(Assignee)

Comment 19

19 years ago
Converting the project to Pro5 (i.e., by opening it with the Pro5 IDE) 
automatically fixes MSL paths.  So we don't have to worry about this.  Plus, in 
the meantime, such a change would stop us from building with the current tools.
saari's projects complete and checked in. 

Comment 21

19 years ago
I just changed all the projects in the commercial tree.

Comment 22

19 years ago
I updated my projects
(Assignee)

Comment 23

19 years ago
The upgrade and documentation are complete thanks to great cooperation on the
part of all the Mac people, but most especially <sfraser@netscape.com> and
<beard@netscape.com>.  Thanks, guys.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.