Firefox crashes after about:plugins and "java.lang.UnsatisfiedLinkError: getProxyConfigURL" error.



14 years ago
8 years ago


(Reporter: lars, Assigned: alfred.peng)


1.7 Branch
Mac OS X

Firefox Tracking Flags

(Not tracked)



(1 attachment)



14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/125.4.2 (KHTML, like Gecko) Safari/125.9
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10

Under MacOS 10.3.5, typing 'about:plugins' in the Firefox location bar results in the error 
"java.lang.UnsatisfiedLinkError: getProxyConfigURL".  Clicking "More details" gives:

java.lang.UnsatisfiedLinkError: getProxyConfigURL
	at Method)
	at sun.plugin.AppletViewer.initEnvironment(
	at jep.MyJavaRunTime.initJavaRunTime(
	at jep.AppletHolderFactory.initProperties(
	at jep.AppletHolderFactory.createAppletHolder(

After dismissing the error dialog, it is no longer possible to enter text in the location bar.  Closing the 
window causes Firefox to crash immediately.

Reproducible: Always
Steps to Reproduce:
1. Enter "about:plugins" in the location bar.
2. Dismiss the resulting error dialog.
3. Close the window.

Comment 1

14 years ago
Created attachment 158965 [details]
CrashReporter log from Firefox crash.

Comment 2

14 years ago
I'm still seeing the same behavior with the 10/1/2004 nightly build.

Comment 3

14 years ago
I can confirm this bug, both on this old build -

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041110
Firefox/1.0 (PowerBook)

- and on the latest official nightly. Tested with empty profiles, too.

Comment 4

14 years ago
what version of java are you using? 1.4.2 update 1? if so, could you try update 2?
Assignee: firefox → kyle.yuan
Component: General → Java: OJI
Product: Firefox → Core
QA Contact: firefox.general
Version: unspecified → 1.7 Branch
The reporter is using a very old version of the Java Embedding Plugin
(0.8.2 or earlier):

(You can tell the Java Embedding Plugin is involved from the
stack-trace lines beginning "jep".  You can tell that he's using a
very old version by the fact that this error was caused by an
incompatibility with Java 1.4.2 Update 1 (and Update 2).  The problem
was fixed in JEP 0.8.3.)

If he wishes to continue to use the JEP, the reporter should upgrade
to the latest version, JEP 0.8.8.  (Another reason to do so is that
version 0.8.8 fixes a security hole to which all previous versions
were vulnerable.)  Otherwise he should uninstall the JEP (the Readme
file, available online, has instructions on how to do this).


13 years ago
Assignee: yuanyi21 → pete.zha

Comment 6

13 years ago
mass reassign to Alfred
Assignee: zhayupeng → alfred.peng
no response
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE


8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.