back button frequently stops short of initial page

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Aaron M. Ucko, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

When I bring up a new browser window by whatever means, the only way to ensure
that the page it starts with remains accessible via Back is to enter a new
location in the location bar; if I instead either follow a link on the page or
go to a bookmark, the new page replaces the previous one as the start of that
window's history.  (However, at that point, it stays there; following a link in
the new page leaves it accessible via Back.)

Reproducible: Always
Steps to Reproduce:
1. Bring up a new browser window.
2. Either follow a link on the page that comes up or go to a bookmark.

Actual Results:  
The back arrow remained grayed, and alt-left had no effect.

Expected Results:  
Made it possible to return to the initial page via the normal Back mechanism.

I did not run into this bug in 0.9.3.  (I initially installed 1.0PR on top of
0.9.3, but then reinstalled into a fresh directory.)

I am using the default theme, but a moderate pile of extensions; it's possible
that one of them is responsible.  Here's the list:

Translation Panel 1.3.6
Disable Targets for Downloads 0.6
JavaScript Debugger 0.9.84
Google Pagerank 0.8
PRGoogleBar 0.9.0.24
McSearchPreview 1.1
Open Long Url 0.1.1
Biobar 1.2
Plain Text Links 0.2
Tabbrowser Extensions 1.1.2004082801

(The tabbrowser extensions are from http://white.sakura.ne.jp/~piro; all others
are from updates.mozdev.org.)
(Reporter)

Comment 1

14 years ago
Aha.  It looks like PageRank 0.8 was at least partly responsible; uninstalling
it seems to have resolved the problem.  (I'm not sure whether it was supposed to
have enough privileges to do that; if it was, you're welcome to close the bug.)

Comment 2

14 years ago
resolving wfm per comment 1. A bad extension may break things. I think you
should contact extension's author on the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: mozilla → bookmarks
You need to log in before you can comment on or make changes to this bug.