CSS does not render/load at all, mime type correct

VERIFIED INVALID

Status

()

Firefox
General
--
major
VERIFIED INVALID
14 years ago
14 years ago

People

(Reporter: Yasmary Mora, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

The CSS for this whole section of the site does not load, or its not being
rendered. In other bugs, it said that the type was incorrect, but this is the
tag used. 

<link href="/about.css" rel="stylesheet" type="text/css">

Tried in 3 different computers, all running Windows XP, 2 running the new
version of FF, one running 0.9.3 and got the same results.

Tried changing the name of the css file, tried deleting everything in the CSS
file and leaving only basic text formatting and its still not rendering. 

Reproducible: Always
Steps to Reproduce:
1. View the page (http://www.about.takingitglobal.org) in IE
2. View the page (http://www.about.takingitglobal.org) in Firefox
3.

Actual Results:  
CSS does not load/render. Regardless of how many times you refresh or force a
refresh.

Expected Results:  
It should render the CSS file.
(Reporter)

Comment 1

14 years ago
Created attachment 158981 [details]
Results if page viewed in IE
(Reporter)

Comment 2

14 years ago
Created attachment 158982 [details]
Results when viewing the page in Firefox

Comment 3

14 years ago
Your CSS file (about.css) is sent to the browser as text/html
You need to change your server setting to it sends text/css over HTTP.

If you're using Apache edit mime.types

Comment 4

14 years ago
The server is saying the mime type is text/html.  This overrules anything in the
<LINK> tag.

This is not a browser bug.  The server admin has to fix the server setting.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

14 years ago
We forced the mime.type to say text/css this fixed the problem with the
http://about.takingitglobal.org site and other sections that had the same problem. 

Although our main site http://www.takingitglobal.org worked fine under the
settings set before. 

Status: RESOLVED → VERIFIED

Comment 6

14 years ago
(In reply to comment #5)
> Although our main site http://www.takingitglobal.org worked fine under the
> settings set before. 

The stylesheet's MIME type is only enforced in standards mode see:

http://www.mozilla.org/docs/web-developer/quirks/

Your main pages are in quirks mode.
You need to log in before you can comment on or make changes to this bug.