bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

RFE: don't delete cookies file when disabling

VERIFIED FIXED in M10

Status

()

Core
Networking: Cookies
P3
enhancement
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: Paul MacQuiddy, Assigned: Paul MacQuiddy)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

20 years ago
Currently the cookies.txt file gets deleted when you disable your cookies. An
end-user has asked that we not delete the file. Here is the quote:

"Sometimes we want to stop netscape from receiving NEW cookies
temporarily but we want to keep the cookies that we already have.   This is
REALLY annoying to have to go and undelete the cookies.txt file from the hard
drive."

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

20 years ago
QA Contact: 3819
(Assignee)

Comment 1

20 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → INVALID

Comment 2

20 years ago
I have a problem understanding this report.  We certainly don't delete the
cookie file when cookies are disabled, at least not intentionally.  So we would
need to test to see if this file is getting deleted by accident.  But there is
no way to test this out since the preferences are not yet implemented in
seamonkey.  So that makes me wonder how the user who reported this ever disabled
his cookies.  I can only conclude that the user must have been confused and that
this bug report is invalid.  Closing it out as such.

If I'm mistaken and someone actually has a test whereby they can demonstrate
this bug, please re-open this report and include the test.
(Assignee)

Updated

20 years ago
Status: RESOLVED → REOPENED
(Assignee)

Updated

20 years ago
Assignee: morse → paulmac
Status: REOPENED → NEW
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

20 years ago
this was filed as a bug in 4.5 code, and I transferred it over to bugzilla so
the same thing would not happen with the 5.0 codebase.

So, no it hasn't been confirmed with apprunner yet, but was put in as a
placeholder with the assumption that the bug would 'carry over' to the 5.0 code.

So I will re-open the bug, and assign it to me to check when the proper
functionality is available, and then assign to you if it still happens...
(Assignee)

Updated

20 years ago
Resolution: INVALID → ---
(Assignee)

Updated

20 years ago
Target Milestone: M6
(Assignee)

Updated

19 years ago
Target Milestone: M6 → M8
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Updated

19 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.