If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

context menu is cut off when right clicking on an image link when related plugins are installed

RESOLVED DUPLICATE of bug 245163

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 245163
13 years ago
11 years ago

People

(Reporter: estebe, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040911 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040911 Firefox/0.10

if i have several plugins added (say adblock, image zoom and nuke anything) and
i right click on a link for which these plugins are enabled (say any picture,
for instance at http://my.yahoo.com ), and that picture link is around the
middle of the page (versus being more distinctly toward the top or bottom), then
the right click menu will incorrectly open down or up in such a way as to cut
off the top or bottom right click menu items.

it seems the right click menu size is not computed including the number of
plugins that might be in it, but is simply assumed to be the standard (ie., no
plugin) size

the right click menu also seems to always opens starting at either the upper or
lower edge of the mouse click (versus opening anywhere in between the top and
bottom edges, if necessary)

otherwise, a wonderful browser!

Reproducible: Always
Steps to Reproduce:
1.install image plugins (adblock, zoom image, nuke anything)
2.right click on image link (any picture on my.yahoo.com) while image is in
middle of page (versus near top or bottom)
3.

Actual Results:  
the right click context menu is then cut off as described in details

Expected Results:  
it should have taken into account the new larger (plugin added) size of the
context menu (versus assuming standard size) and opened it in such a way as to
NOT cut off the full menu from being displayed (which results in disallowing
features such as "open link in new tab")

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 245163 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.