Firefox segfaults on search from search toolbar

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: cefrodrigues, Assigned: p_ch)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

When I try to search using the search toolbar in Firefox 1.0PR1 it segfaults. It
doesn't matter which engine I use or which query I make, it segfaults every
time. This happens both on Linux (Fedora Core 2) and Windows (XP SP2).

Reproducible: Always
Steps to Reproduce:
1.Open firefox
2.select any search engine in the search toolbar
3.search for something

Actual Results:  
Firefox crashes.

Expected Results:  
It should work.
(Reporter)

Comment 1

14 years ago
I've removed the ~/.mozilla/firefox/default.519/chrome/chrome.rdf file and it
doesn't crash anymore (on Linux, on Windows I haven't tried yet).

Updated

14 years ago
Severity: major → critical
Keywords: crash
(Reporter)

Comment 2

14 years ago
Well, I did the same on Windows and it fixed the problem there too. user.rdf
didn't seem to have anything more than leftovers from the portuguese
localization extension (http://mozilla.shopizzy.com/firefox) which I had already
uninstalled right after installing 1.0PR1.

Comment 3

14 years ago
This seems to be the same bug as 238640.
I'll try that.

But it shouldn't happen.

Comment 4

14 years ago
Removing chrome.rdf helped.
No crash with searchbar, and Firefox recognises the default search in context menu.

Comment 5

14 years ago
marking WFM as it works for reporter and everybody else.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.