Privacy Panel: hardcoded background color breaks some themes

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: danielc, Assigned: kevin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a4) Gecko/20040913
Build Identifier: Firefox 1.0PR

The background color of the active item in Tools | Options | Privacy is hard
wired while the text color uses the system's font color.

The Privacy section is the only Option area to use a hardwired background color
for the active item.  Remove the background color.

Reproducible: Always
Steps to Reproduce:
1. Open the options dialog via Tools | Options | Privacy
2. Set Windows' window font color to yellow:
   a. Start Menu | [Settings] | Control Panel | Display
   b. Move the dialog box to the side so you can see TB's Options dialog
   c. Click on the Appearance Tab
   d. Click on the "Window Text" area
   e. Click on the Font Color box near the lower right.
   f. Select yellow.
   g. Hit the Apply button
3. Try to read the text in the FF's Privacy pane.
Actual Results:  
Can't read the text because the font doesn't contrast with the yellow background.

Expected Results:  
Being able to read the text.
Kevin, either we should hardcode both, or use something from nsITheme as the
background color.
Assignee: firefox → webmail
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: options privacy pane: remove background color from active item → Privacy Panel: hardcoded background color breaks some themes
(Assignee)

Comment 2

13 years ago
This isn't present in the new preferences window. Please verify
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.