Extensions blocked from update.mozilla.org

VERIFIED DUPLICATE of bug 257633

Status

()

Toolkit
Add-ons Manager
--
minor
VERIFIED DUPLICATE of bug 257633
14 years ago
10 years ago

People

(Reporter: Lachlan Hunt, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Since I upgraded to 1.0PR, I am unable to install extensions via
http://update.mozilla.org/

The site is listed in the list of allowed sites, and even after removing and
adding it again, I still get the message:

  "To protect your computer, Firefox prevented this site
   (update.mozilla.org) from installing software on your
   computer"

I then tried it from other sites, and they were also blocked.  The only way to
install an extension was to download, and install from my local disk.

To see if I could replicate this issue, I tried various things such as creating
a new profile; uninstalling 1.0 and downgrading to 0.9.3 then creating new
profile, and upgrading again to see if it was just an incompatibility between
profiles or something, but failed to reproduce the same result.  However, every
time I use my original profile, all extensions are still blocked.  I'm assuming
this means my profile has been corrupted, but I don't know how.

Reproducible: Couldn't Reproduce
Steps to Reproduce:
1. Use my original profile, which I have backed up and can provide a copy of the
files, if they would be useful.  Other than that, I have no idea.
Actual Results:  
Extensions are blocked from all websites

Expected Results:  
Extensions should not be blocked after I explicitly allow the site.

Comment 1

14 years ago
see bug 257633 if that's your issue?
(Reporter)

Comment 2

14 years ago
Yes, that was it.  I had "Disable Referrer Logging" enabled in the web developer
toolbar, so this is a duplicate of  bug 257633

*** This bug has been marked as a duplicate of 257633 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.