Display resolution setting doesn't have effect and the Windows dpi setting either

RESOLVED INVALID

Status

()

Firefox
Preferences
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Joost, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

The DPI (normal: 96dpi, big; 120dpi) setting in Windows Configuration - Display
- Settings- Advanced doesn't have effect on Firefox. This is disturbing on
Laptops with XVGA schreens (1400x1050). Internet Explorer works better in this way.
I tried the setting within Firefox (Options - General - Fonts & Colors - Display
resolution. But also this setting doesn't have effect.

Reproducible: Always
Steps to Reproduce:
1.change dpi setting setting in Windows Configuration - Display - Settings-
Advanced in 120 dpi
2. start Firefox and load a page
3. Start Internet explorer and load a page
Actual Results:  
you see a different format of fonts of menu's and in pages between firefox and IE

Expected Results:  
display must be equal between Firefox and IE

Comment 1

13 years ago
Setting DPI in Firefox settings in Windows is known to not work. Only setting
the system DPI will affect Firefox DPI on Windows.

You do not have both Firefox and IE using the same language for the main menus,
so I can't tell whether their fonts should look the same. When I use Win98 at
120 DPI with English menus in both browsers, the menu fonts are exactly the same
size.

Firefox should display the same as IE only when the web page designer intends
for that to happen. On http://portal.omroep.nl/nieuws/, the designer has
manifested no such intent. Instead, he has set font sizes using relative values
based upon the setting of the visitor's browser default. When Windows is set to
120 DPI, the IE default size is 20px. For Firefox to render that page the same,
you as the user must set Firefox's default equal to IE, 20px. When I do that,
that page looks almost exactly the same in IE and Firefox.

If you look at http://members.ij.net/mrmazda/auth/PointsDemo.html both at 96 DPI
and at 120 DPI with both Firefox and IE, you will, except for one paragraph
labeled as showing you your browser default size, see virtually identical
rendering in both browsers. This page does depend on DPI, unlike the page in
your screenshot. Only the one mentioned paragraph will be materially different
between the two browsers, and then only when the default size of the two
browsers are not intentionally matched by you as the browser user.

Since this bug complains about two different problems, menu font sizes, and page
font sizes, it constitutes an invalid bug, for that reason alone. The fact that
the web page your screenshot is not designed to look the same when browser
default sizes are not the same also makes this bug invalid. Marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.