Between 1.6 and 1.7 Mozilla has stopped displaying generated content after img tags

RESOLVED DUPLICATE of bug 245633

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 245633
14 years ago
14 years ago

People

(Reporter: James Noonan, Assigned: David Baron)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

The title attribute of the img tag should appear after the image as a caption
and did in Mozilla 1.6, but does not in Mozilla 1.7.

Reproducible: Always
Steps to Reproduce:
1.markup an image with an image tag and put some text in the title attribute
2.img[title]:after as a selector
3.content:attr(title); as property

Actual Results:  
Nothing was displayed

Expected Results:  
The title attribute of the img tag should appear after the image as a caption.

Comment 1

14 years ago
Mozilla is correct in doing so.

*** This bug has been marked as a duplicate of 245633 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Mozilla is correct in doing so.
> 
> *** This bug has been marked as a duplicate of 245633 ***

Thank you, I assume you're referring to the CSS3 content working draft
(http://www.w3.org/TR/2003/WD-css3-content-20030514/). Replaced element was just
enough information to find it.

Again thanks for the prompt response.
You need to log in before you can comment on or make changes to this bug.