Gmail never finishes loading, the icon continues to be the loading one (but otherwise Gmail works fine)

VERIFIED WORKSFORME

Status

()

--
minor
VERIFIED WORKSFORME
14 years ago
5 years ago

People

(Reporter: rsanchez.saez, Assigned: darin.moz)

Tracking

Trunk
mozilla1.8beta1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When you log in a www.gmail.com account, the page never finishes loading
completely and Mozilla keeps displaying the rolling loading icon forever. Gmail
interface works fine despite this. This problem is not present when using
Internet Explorer.

I have been asking and some people experience this, others have this sometimes,
while other people don't experience this. I have this problem every single time
I log on on my Gmail account. I have tried uninstalling all extensions, creating
a new profile and clearing the cache to no avail.

Reproducible: Always
Steps to Reproduce:
1. Log in at www.gmail.com

Actual Results:  
Page looks and works correctly, but never finishes loading.

Expected Results:  
Page should finish loading.

Comment 1

14 years ago
It does the same thing for me. Using 20040911 .10
(Assignee)

Comment 2

14 years ago
yeah, i've been annoyed by this too... i figure it must be something having to
do with the XMLHttpRequest object, but i haven't had time to investigate it yet.
 has anyone else?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

14 years ago
Severity: normal → minor
Target Milestone: --- → mozilla1.8beta

Comment 3

14 years ago
No problem for https://gmail.google.com
(Reporter)

Comment 4

14 years ago
I forgot: I have also reported this to Gmail, in case they are not complying
with standards or it is a bug on their end or something.

Comment 5

14 years ago
seeing same, Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a4) Gecko/20040914
(Assignee)

Comment 6

14 years ago
(In reply to comment #4)
> I forgot: I have also reported this to Gmail, in case they are not complying
> with standards or it is a bug on their end or something.

Ok, good to know, thanks!  Because in my case even the STOP button doesn't work,
I suspect that there is something here that Mozilla is not doing right.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040915
Firefox/0.10

There are more sites where this happens (mostly html chats)

additional to comment #0
1.Open FF
2.Open a # of tabs
3.Open Gmail in one of them and hope it never stops loading
4.close the tab containg Gmail
notice that when you move your mouse over the chrome of the window the cursor
turns into a hourglass, indicating an ongoing loading process.
This behaviour can only be stopped by terminating the window.

Comment 8

14 years ago
I´ve installed extension LiveHTTPHeaders, and after starting the browser, left
Gmail idling alone for some minutes, no other tabs open, nor windows.
DUN status was showing the reception of 16 bytes every 10 seconds, as usual,
maybe that´s keep-alive, don´t know. Happens always, everywhere.

http://livehttpheaders.mozdev.org/

There is a conversation repeating every two minutes, the server sets a new
cookie, which is used at the next GET 2 minutes later.
I replaced some lengthy hexnbrs or strings with 'xxx' to improve readability,
and be sure nobody could use this info to access my account.

http://gmail.google.com/gmail?view=tl&search=inbox&start=0&tlt=xxx&fp=xxx&auto=1&zx=xxx

GET /gmail?view=tl&search=inbox&start=0&tlt=xxx&fp=xxx&auto=1&zx=xxx HTTP/1.1
Host: gmail.google.com
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a4) Gecko/20040914
Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,fr-fr;q=0.8,de-de;q=0.5,es;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Referer: http://gmail.google.com/gmail?search=inbox&view=tl&start=0&init=1&zx=xxx
Cookie: SID=ATxxx=; GV=xxx; TZ=-120; PREF=ID=xxx:TM=xxx:LM=xxx:GM=1:S=xxx;
GMAIL_AT=xxx; S=gmail=xxx:gmproxy=xxx

HTTP/1.x 200 OK
Set-Cookie: SID=AQxxx=;Domain=.google.com;Path=/;Expires=Sun, 14-Sep-2014
21:11:33 GMT
Cache-Control: no-cache
Pragma: no-cache
Content-Type: text/html; charset=utf-8
Content-Encoding: gzip
Transfer-Encoding: chunked
Server: GFE/1.3
Date: Thu, 16 Sep 2004 21:11:33 GMT

Silly question, off topic: If I allow google cookies, and disallow third party
cookies, are google cookies allowed on the newstickers were google ads are placed?
I have seen the same behaviour on my FF.10. Before one minute i tested and
noticed following: The site consists of a frameset. I started to show only one
frame by opening the context menu out of the middle of the page. This frame was
loaded and the progress indicator stops now. That looks good and I reloaded the
homepage again. Now the problem that the site doesn't stop loading is away. I
cleared the whole cache but it is still ok for me now. The only thing i'm not
tested yet, is to restarting FF.

Comment 10

14 years ago
Bug 248749 is also about never ending pageloads, somehow related?

Comment 11

14 years ago
(In reply to comment #3)
> No problem for https://gmail.google.com

Confirmed, and I was seeing it pretty consistently before. Even more bizarrely,
after trying that I now can't reproduce the problem for http either.

Comment 12

14 years ago
This happens to me, but only when going via Privoxy. If I turn off privoxy, it
stops happening.

Comment 13

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

I have the same problems, yet it does not happen in other versions of Firefox.
Not sure what changed. Happens on my OSX Machine too, so its not a windows
specific problem.
(In reply to comment #13)
> Not sure what changed. Happens on my OSX Machine too, so its not a windows
> specific problem.

OS => ALL, Hardware => ALL
OS: Windows XP → All
Hardware: PC → All
should be 

Version->Undefined (both trunk/branch)

, but the option is missing

Comment 16

14 years ago
I started seeing this a week or two ago, but it was with an August build of
Firefox that I had been using for a few weeks with no problems.  Mozilla 1.7.2
shows this problem as well.

http and https doesn't seem to make a difference for me.

I'm really interested in what Gmail's response is, as it seems pretty clear to
me that this is not caused by a change in Mozilla.
(Reporter)

Comment 17

14 years ago
Gmail replied to me with a prefabricated message that did not solve the problem,
but it said that if I needed further assitance that I should reply and I did so,
I am waitint for them to reply again.

It would be a good idea if some of you guys reported this problem too, so they
see that is not a one time issue.
frankly, if mozilla's throbber never stops, that is by definition a mozilla bug,
because if nothing else, a timeout should occur. likewise, darin's comment 6
indicates a bug too, possibly the same one.
I've seen that the js console throws a lot of (strict) js warnings. All warnings
appears within following lines:

Warning: deprecated arguments usage
Source File: https://gmail.google.com/gmail?view=page&name=js&ver=xxx
Line: 6

Warning: reference to undefined property this[":" + Dd]
Source File: https://gmail.google.com/gmail?view=page&name=js&ver=xxx
Line: 71

Warning: deprecated arguments usage
Source File: https://gmail.google.com/gmail?view=page&name=js&ver=xxx
Line: 78

Warning: reference to undefined property S(a).suspend_events
Source File: https://gmail.google.com/gmail?view=page&name=js&ver=xxx
Line: 104

Warning: reference to undefined property Ca.sx_rt
Source File: https://gmail.google.com/gmail?view=page&name=js&ver=xxx
Line: 510

I don't know if that could cause the endless loading.

Comment 20

14 years ago
I have seen this bug before quite a lot on other webpages too, at least since FF
0.8, maybe even longer back. Most noticably I have seen this happen when you
refresh a page. The throbber (that's the cycling circle icon IIRC) just keeps on
going and the statusbar never says 'done'. I have seen this on many sites and
most notably on phpBB forums. I frequent www.419eater.com/forum/index.php and it
happens there too. I double checked with the developers site at
www.phpbb.com/phpbb/index.php but the same error happens there.

1) Go to the URL. 
2) wait for the page to load fully
3) hit 'refresh'
4) the page never finishes loading. The statusbar alsays says 'waiting for
<host>'. If there is no favicon.ico then the throbber will continue to cicrle.

Note that 419eater and phpbb.com have a favicon so the throbber will go away,
but the statusbar will continue to show 'waiting for <host>'. I could not
quickly find a phpBB board without a favicon.ico 
Perhaps related to bug 257875 ?

I'm seeing this quite often (Win98, Win XP), only since 1.0PR (or perhaps a few
nightlies earlier).
(In reply to comment #18)
> frankly, if mozilla's throbber never stops, that is by definition a mozilla bug,
> because if nothing else, a timeout should occur. likewise, darin's comment 6
> indicates a bug too, possibly the same one.
The problem is actually worse than that.
I did some test tonight 
1. I opened a page with a simple animated gif
2. I tried to open "feedhouse" (http://feedhouse.mozillazine.org/)in a second tab.
3. Feedhouse would not load, causing the endless spinn of the throbber.
4. I went back to the tab with the animated gif and noticed it stopped every
time FF was attempting to load Feedhouse.
5. I went back to the feedhouse tab and closed it.
6. The pages with the animated gif however was still stopping every few secs ,
like FF was still trying to load feedhouse.
7. The only way to make the ani gif work normally again was to open a new tab.

ergo.
It appears that closing a tab does not stop a process that was going on in that
tab.It is only stopped after you close the tab and open a new one.
(if the endlessly loading tab contains an applet or pdf and it is closed , the
browser simply crashes. )

Comment 23

14 years ago
I do believe Gmail has fixed this on their end.  Works properly in all
variations of Mozilla I've thrown at it.

Comment 24

14 years ago
I can confirm that this is fixed for me too.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040925
Firefox/0.10

I'm still seeing the problem

Comment 26

14 years ago
I've found that if you open Gmail in another tab when this happens (I have it
bookmarked), then the second tab opens while the first one still hangs.
(Assignee)

Comment 27

14 years ago
this could very well have been a duplicate of bug 257875.
(Assignee)

Comment 28

14 years ago
It's been months since I've seen this problem.  Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.