Showing menu item for bookmark of missing share causes hang

RESOLVED DUPLICATE of bug 273198

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 273198
14 years ago
12 years ago

People

(Reporter: Ben Hutchings, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.3) Gecko/20040913 Firefox/0.10

If I try to open the Bookmarks menu after having opened another menu, and I have
not yet used the Bookmarks menu in this session, the browser hangs for a minute
or so. This does not happen if the Bookmarks menu is opened directly the first
time and it does not happen on subsequent openings.

Reproducible: Always
Steps to Reproduce:
1. Start Firefox.
2. Select the Tools menu.
3. Move the pointer over to the Bookmarks menu.

Actual Results:  
Browser hung for a little over a minute.

Expected Results:  
Shown the Bookmarks menu almost immediately.
(Reporter)

Comment 1

14 years ago
Actually this bug is not restricted to the situation I first described. I have
now seen it (1) when starting Firefox and immediately attempting to open the
Bookmarks menu, and also (2) on a subsequent attempt to open of the Bookmarks menu.

In case (2) I had been running another app that used a lot of memory, so that
opening the Bookmarks menu might have required paging in some data.
Unfortunately the disk LED on my PC is not easily visible so I don't know
whether this is what happened. In both this case and that of the first use of
the Bookmarks menu, it should take a second or two to load data before
displaying the menu, whereas normally it would take very little time at all. So
I suspect the bug may be timing-related. Note that in case (2) the disk was idle
by the time I thought to check it; the browser remained unresponsive for about a
minute after that, so the hang wasn't directly due to paging.
Summary: Hang if the Bookmarks menu is first opened while another menu is open → Hang if the Bookmarks menu is slow to open

Comment 2

14 years ago
I believe I'm seeing this in 1.0 PR on Windows XP.  It's fairly consistent.  I'd
add that if I let it whirl sometimes it recovers, and sometimes it crashes hard
(with the quality agent most (all?) of the time.  I also have a couple of RSS
feeds bookmarked via the new RSS button.

This is a big pain because I essentially crash the browser everytime I
accidentally expand the bookmarks menu.  

(Note: I'm adding this comment to a few existing bugs that seem to match my
symptoms.)
Assignee: vladimir → vladimir+bm
(Reporter)

Comment 3

13 years ago
Still present in 1.0 release.
Version: unspecified → 1.0 Branch
(Reporter)

Comment 4

13 years ago
I've narrowed this down to a particular bookmark. The bookmark had a URL of the
form <file://///server/share/...>, and the named server no longer exists. I
think Firefox asks Windows for an icon for the target of the bookmark and the
underlying Windows function attempts to contact the server and consequently
hangs. In recent versions of Firefox the first click on the Bookmarks menu would
always cause a temporary hang; I don't know what might have caused the change
from the originally reported behaviour but it's not really important.

I suggest that Firefox should not do anything that requires resolving a UNC path
in a bookmark until the bookmark is opened.

Comment 5

13 years ago
Created attachment 196868 [details]
My bookmarks file

I two am having this problem - First click on the Bookmarks menu and it takes
20 seconds to show the menu.  This attachment is my bookmark file.  Replace
your bookmark file with this one, close all browsers, open Firefox, click on
Bookmarks, WAIT, bookmarks show up.  I'm using Windows XP, and I think my
system is disk-bound, meaning that the hard drive causes more slowness than
memory or processor speed on my machine.

Comment 6

13 years ago
I believe that 265475 is a duplicate of this bug.
(Reporter)

Comment 7

13 years ago
Glen, I think #265475 is quite different, as it's about startup time and depends
on the number of bookmarks and not their targets. I'm changing the title of this
to indicate the precise problem I identified.
Summary: Hang if the Bookmarks menu is slow to open → Showing menu item for bookmark of missing share causes hang
Assignee: vladimir+bm → nobody
*** Bug 313832 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago

*** This bug has been marked as a duplicate of 273198 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.