If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox will not show a frame that has 'ad' surrounded by numbers (i.e. 1ad1)

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Trevan, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

I first noticed this when a phpMyAdmin (on one of the sites I handle) wouldn't
display the left frame.  I thought it was phpMyAdmin but couldn't find an
answer.  So I decided to copy the source and see if changing things will work. 
I discovererd that the two culprite frames had an src of
"left.php?something&hash=ad0209ontblah".  By deleting each character and
reloading, the ad0 turned out to always cause the problem.  So I created another
page just to test this hypothesis:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN"
"http://www.w3.org/TR/html4/frameset.dtd">
<html>
<head>
<title>phpMyAdmin 2.5.2-pl1 - www.ckiweb.com</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" >
</head>
<frameset cols="150, *">
<frame src="1ad1.php" >
<frame src="test2.php" >
</frameset>
</html>
I verified that it was valid HTML (phpMyAdmin uses XHTML and I had that
validated too).  Running this page only shows test2.php.  1ad1.php isn't even
called from the server (LiveHTTPHeaders told me that).  I have also changed that
src to left.php?1ad1 and I get the same problem.  The numbers can change and
extra characters can be added around the numbers but 'ad' has to be surrounded
by at least one number on each side. (I believe the error will occur with 'ad'
surrounded by anything but characters i.e. ?ad&)

Another URL with XHTML and the 'ad' inside the GET is
http://students.cs.byu.edu/~tdr32/test.php

Reproducible: Always
Steps to Reproduce:
1. View Web Page.
Actual Results:  
In test1.php, only the right frame loads
In test2.php, the left-top frame won't load

Expected Results:  
All the frames should load

Comment 1

13 years ago
Works for me in Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040915 Firefox/0.10

a) Please upgrade to a recent version of Firefox and retest.
b) Please ensure your are not using any extensions or tweaks (especially ad
blockers) and retest.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040915
Firefox/0.10

WFM

it almost sounds like you have Adblock installed
(Reporter)

Comment 3

13 years ago
Yea, it did turn out to be ad block.  I thought I had started a new session but
I guess not.  The problem is fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.