can't re-use same profile name after deleting profile dir

VERIFIED DUPLICATE of bug 26317

Status

P3
normal
VERIFIED DUPLICATE of bug 26317
19 years ago
3 years ago

People

(Reporter: waterson, Assigned: racham)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
On Win32:

1. Create a profile named "foo". Run the browser, yay.

2. Delete the profile directory, mozregistry.dat, and component.reg

3. Try to create the profile named "foo" again. You'll get an error that "the 
profile with that name already exists".

4. Run "mozilla -ProfileManager" to try to delete the profile. Oops, no profile 
named "foo" in the list to delete.

We shouldn't allow idiots like myself to be backed into such a situation. :-)

(P.S. is there any workaround I can use right now?)

Comment 1

19 years ago
mozilla -ProfileManager is not working right now (bug 24911) try mozilla 
-SelectProfile to see what is in list as a workaround.

I couldn't reproduce this- after deleting registry, profile dir and component 
reg. Is  it possible one of those did not get deleted? 
(Reporter)

Comment 2

19 years ago
Ok, I dug a little further and this is what I think happened. I was trying to
use the same profile name as my Nav 4.x profile ("waterson") which I hadn't yet
migrated. I thought that -ProfileManager would show me any un-migrated profiles
(it didn't...)

Comment 3

19 years ago
Bhuvan, is this a side-effect of 24911 where unmigrated profiles are not showing 
in the profile manager?  At the very least, in this situation we should prompt 
the user to migrate the profile with that name rather than simply failing.  At 
some point, the UI needs to be consistent with the data...
Assignee: selmer → racham

Comment 4

19 years ago
Marking M14.
Target Milestone: M14
(Assignee)

Comment 5

19 years ago
This infact is the side effect of bug 26317. Right now, the 4x profile 
information is getting transfered always. So, even before throwing 
createProfileWizard the informationis getting into the internal data structures 
and not letting the user to pick the same name. With the fix to bug 26317, we 
will have this information migration happening only with -installer option. And 
when ran with -installer option, it will do the right thing depending on the 
number old and new profiles.

-ProfileManager seems to be working fine (atleast from the yesterday night's 
build). We can use that to do the profile activities.

Making this a dup of bug 26317.

*** This bug has been marked as a duplicate of 26317 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 6

19 years ago
.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.