Advanced Account Settings window does not size propertly----options unavailable.

RESOLVED WORKSFORME

Status

Thunderbird
Account Manager
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Chris Ellison, Assigned: Scott MacGregor)

Tracking

unspecified
x86
Windows XP
Bug Flags:
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When editing Advanced Account Settings....when having one email account store
its messages in the inbox of another email account, the window does not size
properly.  When clicking the radio button "Inbox for different account," a text
field appears and a checkbox that says "Include this server when getting new
mail".  

This updated window does not display all of the items properly.  In fact, some
of them, like the cancel button, are no longer accessible.  I am guessing that
there is another button to the right of the text field that isn't appearing at
all.  See the picture that I have made available.  Clearly, the window isn't
resizing properly---you can see that only the leftmost part of the "Cancel"
button shows.

Reproducible: Always
Steps to Reproduce:
1. Tools -> Account Settings...
2. Select an account -> Server Settings -> Advanced...
3. Select "Inbox for different account"

Actual Results:  
New items appear in the window, but the window is not sized properly to display
the items. NOTICE: The window cannot be manually resized.

Expected Results:  
The new items should be visible---the window should resize properly or allow
manual resizings.

Picture at http://www.plu.edu/~ellisocj/bug.png
(Reporter)

Comment 1

14 years ago
This bug has crept into Thunderbird .9 as well.  The same exact problem, the
same exact steps to duplicate it.  Notice...Advanced Account Settings are UNUSABLE.

Comment 2

14 years ago
I don't have this using Tb 1.0 on WinXP. Can you still reproduce this?

(also removed url, gives 404)
(Reporter)

Comment 3

14 years ago
Yeah, I was still able to reproduce the sizing issue.  This time I am using
version 1.0 (20041206) on Windows XP.  I will post another picture.
(Reporter)

Comment 4

14 years ago
Created attachment 170937 [details]
Picture of resizing issue in Thunderbird 1.0

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.1?

Comment 5

14 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10
> 
> When editing Advanced Account Settings....when having one email account store
> its messages in the inbox of another email account, the window does not size
> properly.  When clicking the radio button "Inbox for different account," a text
> field appears and a checkbox that says "Include this server when getting new
> mail".  
> 
> This updated window does not display all of the items properly.  In fact, some
> of them, like the cancel button, are no longer accessible.  I am guessing that
> there is another button to the right of the text field that isn't appearing at
> all.  See the picture that I have made available.  Clearly, the window isn't
> resizing properly---you can see that only the leftmost part of the "Cancel"
> button shows.
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. Tools -> Account Settings...
> 2. Select an account -> Server Settings -> Advanced...
> 3. Select "Inbox for different account"
> 
> Actual Results:  
> New items appear in the window, but the window is not sized properly to display
> the items. NOTICE: The window cannot be manually resized.
> 
> Expected Results:  
> The new items should be visible---the window should resize properly or allow
> manual resizings.
> 
> Picture at http://www.plu.edu/~ellisocj/bug.png

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10
> 
> When editing Advanced Account Settings....when having one email account store
> its messages in the inbox of another email account, the window does not size
> properly.  When clicking the radio button "Inbox for different account," a text
> field appears and a checkbox that says "Include this server when getting new
> mail".  
> 
> This updated window does not display all of the items properly.  In fact, some
> of them, like the cancel button, are no longer accessible.  I am guessing that
> there is another button to the right of the text field that isn't appearing at
> all.  See the picture that I have made available.  Clearly, the window isn't
> resizing properly---you can see that only the leftmost part of the "Cancel"
> button shows.
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. Tools -> Account Settings...
> 2. Select an account -> Server Settings -> Advanced...
> 3. Select "Inbox for different account"
> 
> Actual Results:  
> New items appear in the window, but the window is not sized properly to display
> the items. NOTICE: The window cannot be manually resized.
> 
> Expected Results:  
> The new items should be visible---the window should resize properly or allow
> manual resizings.
> 
> Picture at http://www.plu.edu/~ellisocj/bug.png

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10
> 
> When editing Advanced Account Settings....when having one email account store
> its messages in the inbox of another email account, the window does not size
> properly.  When clicking the radio button "Inbox for different account," a text
> field appears and a checkbox that says "Include this server when getting new
> mail".  
> 
> This updated window does not display all of the items properly.  In fact, some
> of them, like the cancel button, are no longer accessible.  I am guessing that
> there is another button to the right of the text field that isn't appearing at
> all.  See the picture that I have made available.  Clearly, the window isn't
> resizing properly---you can see that only the leftmost part of the "Cancel"
> button shows.
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. Tools -> Account Settings...
> 2. Select an account -> Server Settings -> Advanced...
> 3. Select "Inbox for different account"
> 
> Actual Results:  
> New items appear in the window, but the window is not sized properly to display
> the items. NOTICE: The window cannot be manually resized.
> 
> Expected Results:  
> The new items should be visible---the window should resize properly or allow
> manual resizings.
> 
> Picture at http://www.plu.edu/~ellisocj/bug.png

(In reply to comment #4)
> Created an attachment (id=170937) [edit]
> Picture of resizing issue in Thunderbird 1.0
> 

This problem seems to be related to screen resolution.  E.g., on this D600 I'm
using, if the resolution is reset from 1400x1050 down to 1024x768, the window
sizes correctly and is not truncated on the right side.
(Assignee)

Updated

13 years ago
Flags: blocking-aviary1.1? → blocking-aviary1.1-

Comment 6

13 years ago
Based on the screenshot in attachment 170937 [details], this bug as reported no longer 
applies, as the Advanced settings is no longer a tabbed dialog -- SMTP settings 
are handled differently (and much better), no longer requiring a tab.  The new 
scheme is available now in trunk builds (not 1.0.2 nor any subsequent 1.0 
releases), and will be in TB 1.1.

However, see bug 278067: there are other, different, and consistent sizing 
issues for the Advanced POP Settings window.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.