Failure to play , 100% reproducible

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Michel Bougon, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20040910

This URL fails to play in 1.7.3 ... 

http://vas.virage.com/vss-bin/vss_RealVideo.pl/cspan_booknotes/play/Q0ROPURpZ2l0YWxpc2xhbmQ=/cHJveHlfdXJsPXJ0c3A6Ly9zZi1zdHJlYW0vY3NwYW4vYm9va25vdGVzL29wZW5fc2VnbWVudHMvYjA5MTIwNGdtY2dvdmVybi9iMDkxMjA0Z21jZ292ZXJuLnJt/cHJveHlfb2Zmc2V0PS0xNg==/dGltZWluX21zZWM9NjAxMDk=/dGltZW91dF9tc2VjPTM1MDg1NDc=.smil

(Apparently the error message is irrelevant because Apple's Quicktime shows up
instead of Realplayer)

When this URL is plugged into the Mozilla Web-sniffer, the true Realplayer RM
link is revealed

src="rtsp://cspanrm.fplive.net/cspan/c-span/b091204gmcgovern.rm"

If the sniffer can peel off the overcoding,  should not Mozilla be able to do it
 too ?

Cheers 
Michel


Reproducible: Always
Steps to Reproduce:
1. Copy-and-Paste the above URL
2.
3.

Actual Results:  
Getting a failing Quicktimeplayer instead of the Realplayer

Expected Results:  
External Realplayer should be playing the RM
rtsp://cspanrm.fplive.net/cspan/c-span/b091204gmcgovern.rm
it looks like both quicktime and real register for the application/smil mime
type... I'm not sure mozilla can do much about that...

maybe you can configure the quicktime plugin not to play SMIL files.
Assignee: general → nobody
Component: DOM: Mozilla Extensions → Plug-ins
QA Contact: ian → core.plugins
(Reporter)

Comment 2

14 years ago
Hi cbiesinger

(1) I looked up Quicktime Properties --  Every format was unchecked, except for
only one, "QuickTime Movies" ("mov")

(2) I loooked up Mozilla's Helpers -- There was nothing for "application/smil"
... So, I entered one that points to the Realplayer ... ... Now, the immense 
http://site/xxxxx.smil  is working, with Mozilla properly loading and starting
Realplayer.

Thank you very much for your successful help !

Michel
PS --  When CSpan switched to SMIL for their archives, it would have been nice
if they would have added a warning or notice on their webpage!!!  (For years,
they had been using RAM)

good to hear that it works for you now. closing this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.