Quick Search is now too small

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Luke deGruchy, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.8

The Quick Search has gotten smaller and is placed to the right of the search
bar, unlike the quick search in 0.7.3.  This allowed me to move my mouse pointer
quickly to the quick search text bar, because my mouse point always tends to be
in the middle of the screen.   I also made liberal use of the Clear button to
the right of the quick search.  This allowed me to quickly clear the results of
my previous search, so I could search again.  Now I have to waste another couple
of seconds highlighting the results with my mouse and clear them. 

I prefer the way it was set up in 0.7.3, and I refuse to upgrade to 0.8 because
of it.   I don't mind the dropdown selection of Sender, Subject, etc.   However,
this is what I need in order to upgrade, in order of preference:

1) Quick Search centred in middle of search bar as it was before or with the
option of moving it to the centre.

2) Clear button to the right of the quick search.

3) The ability to stretch out the search bar to be as long as it was before.

I get hundreds of emails a day at work, and it's ESSENTIAL that I be able to
filter my messages quickly and intuitively.   The quick search in 0.7.3 and
previous versions allowed me to filter my mail efficiently and made me productive.

I will NOT upgrade to a version higher than 0.7.3 until this is resolved.

Reproducible: Always
Steps to Reproduce:
1.  Look at the search toolbar


Actual Results:  
The quick search bar is smaller and to the right (not centred) and it no longer
includes the clear button.

Expected Results:  
The quick search should be as it was before.  I don't mind if it includes the
new selection of subject, sender, etc.

Comment 1

14 years ago
Clear button is bug 255643; leaving this as a bug about the size of the field.

PS: Nobody cares whether you upgrade.
Summary: Quick Search is less usable... It's too small and to the right, and no clear button. Was far better in previous version → Quick Search is now too small
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Clear button is bug 255643; leaving this as a bug about the size of the field.
> 
> PS: Nobody cares whether you upgrade.

I'm pointing out how important this feature is to me, I'm not trying to tell you
how to do your job.

You should try to work on your people skills a bit.   It might be a good career
move.

Comment 3

14 years ago
I think this shouldn't be considered hardware or OS specific, as I was about to
file this same bug for OS X.

I find the smaller search field to be less useable than the corresponding field
from 0.7.3; plus the size doesn't appear to be modifiable (via userChrome.css or
some preference setting).
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 5

13 years ago
The bug was filed because of a change in functionality in 0.8 that:

1) Reduced the size of the search bar from one that took up all of the space
next to the view dropdown in the left part of the search bar
2) The lack of clear functionality for the search bar.

2) has been resolved for several releases now.  1) is still not "fixed" if
that's the correct word to use.

It's a question of preference.  Many users may prefer a smaller search text
field to the right of the search bar.  I would prefer a larger search text field.

From what I gather, the reason the smaller search bar was included was because
it was a standard component that was more easily "pluggable" into the interface,
and thus more easily maintainable, from a developer's perspective.

So, if I'm the only person complaining about this, by all means, close the
issue.  If a significantly large number of other users would prefer a larger
search bar, then it should remain an open issue.

From what I gather from your comment, I'm the only person who still thinks this
is an issue.  If so, then it's really not worth keeping this open.

(In reply to comment #4)
> This is an automated message, with ID "auto-resolve01".
> 
> This bug has had no comments for a long time. Statistically, we have found that
> bug reports that have not been confirmed by a second user after three months are
> highly unlikely to be the source of a fix to the code.
> 
> While your input is very important to us, our resources are limited and so we
> are asking for your help in focussing our efforts. If you can still reproduce
> this problem in the latest version of the product (see below for how to obtain a
> copy) or, for feature requests, if it's not present in the latest version and
> you still believe we should implement it, please visit the URL of this bug
> (given at the top of this mail) and add a comment to that effect, giving more
> reproduction information if you have it.
> 
> If it is not a problem any longer, you need take no action. If this bug is not
> changed in any way in the next two weeks, it will be automatically resolved.
> Thank you for your help in this matter.
> 
> The latest beta releases can be obtained from:
> Firefox:     http://www.mozilla.org/projects/firefox/
> Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
> Seamonkey:   http://www.mozilla.org/projects/seamonkey/
> 

Comment 6

12 years ago
(In reply to comment #5)
> if I'm the only person complaining about this, by all means, close the
> issue.  ... it's really not worth keeping this open.

closing as WFM based on paraphrase above.

note despite the smaller field size (43 characters btw) it is quickly accessed via ctrl-k ... so it's not necessary to mouse to it.  and mouse is not needed to clear the field - ctrl-k (selects everything in the field) and hit delete
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.