bankofamerica.com - page renders differently on MSIE

RESOLVED DUPLICATE of bug 237145

Status

--
major
RESOLVED DUPLICATE of bug 237145
14 years ago
3 years ago

People

(Reporter: toohard4ur, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

The page at
https://onlineid.bankofamerica.com/cgi-bin/sso.login.controller?state=CA renders
with an offset the cause it not visible entirely.

Reproducible: Always
Steps to Reproduce:
1.go to https://onlineid.bankofamerica.com/cgi-bin/sso.login.controller?state=CA
2.
3.

Actual Results:  
not full page is visible

Expected Results:  
full page should be visible

Updated

14 years ago
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Browser
QA Contact: firefox.general → core.layout
Version: unspecified → 1.7 Branch

Comment 1

14 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a4) Gecko/20040914

DOM Inspector shows for BODY:
Position: x:0 y:0
box width:    792    box height:   644
margin-top:   -16px  margin-right:   8px
margin-bottom:  8px  margin-left:  -16px

borders, padding = 0

Links to stylesheets:
https://onlineid.bankofamerica.com/images/weas/stylesheet/weas_win_ns4.css
https://onlineid.bankofamerica.com/images/weas/stylesheet/win_ns4.css

I then tried to view the page using Opera, they told me I´ve got Opera 7.54 and
 should go get another browser, offering me two links for convenience.
I tried the Netscape link, then Microsoft, to no avail.

Comment 2

14 years ago
-> Tech Evangelism, Mozilla is correct in rendering.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: Layout → English US
Ever confirmed: true
OS: Windows XP → All
Product: Browser → Tech Evangelism
QA Contact: core.layout → english-us
Hardware: PC → All
Version: 1.7 Branch → unspecified

Comment 3

14 years ago
the page renders fine with Netscape7.2, but not with Mozilla, as Mozilla gets
stylesheets made for Netscape 4.x

I revisited the page with Mozila 1.7.3, same result, and Netscape7.2, working fine.

Netscape7 gets different stylesheets:
https://onlineid.bankofamerica.com/images/weas/stylesheet/win_ns6.css
https://onlineid.bankofamerica.com/images/weas/stylesheet/weas_win_ns6.css

They don´t seem to know that Netscape 6 descends from mozilla 0.6, 
that Netscape7.0 descends from Mozilla 1.0, 7.1 from mozilla 1.4, 7.2 from
Mozilla 1.7.2, so the same stylesheet they are using for Netscape7 would do for
Mozilla 1.x

Replacing

<!-- pkc common css beg -->
	<link rel="stylesheet" type="text/css" href="/images/weas/stylesheet/win_ns4.css">
	<link rel="stylesheet" type="text/css"
href="/images/weas/stylesheet/weas_win_ns4.css">

<!-- pkc common css end -->

with

	<link rel="stylesheet" type="text/css" href="/images/weas/stylesheet/win_ns6.css">
	<link rel="stylesheet" type="text/css"
href="/images/weas/stylesheet/weas_win_ns6.css">

should solve this problem.


FAQ:

http://www.bankofamerica.com/onlinebanking/index.cfm?template=faq_security#browsers


They recommend not to use beta browsers, and block Opera 7.54 because of lacking
support for 128bit encryption.
Summary: page renders differently on MSIE → bankofamerica.com - page renders differently on MSIE

*** This bug has been marked as a duplicate of 237145 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.