Repeated username/password prompts when using Microsoft ISA proxy

RESOLVED DUPLICATE of bug 256949

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 256949
13 years ago
13 years ago

People

(Reporter: Tony Ronan, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

When using Firefox 1.0pre accessing the Internet via a Microsoft ISA 2000 proxy
server I get multiple username/password prompts, seems to be for every item on
the page. Firefox 0.9.3 did not have this problem. The problem only occurs on
clients that are NOT in the same domain as the ISA proxy. Clients that are
members of the same domain as the ISA proxy work correctly without any prompts
at all. Firefox 1.0 is barely usable under these circumstances. A colleague of
mine suggests that this is a fault in Firefox's handling of NTLM dialog.

Reproducible: Always
Steps to Reproduce:
1. set proxy settings to point to ISA proxy server
2. browse website e.g. www.ibm.com
3. 

Actual Results:  
This example site generates 6 username/password prompts

Expected Results:  
For clients not in the domain one username/password prompt at start of session
For clients in the domain, no prompts at all
This is definitly a dupe, but I can't find the right one

Comment 2

13 years ago
I would like to confirm this bug report. I am not sure about our proxy
specification, but it is a Microsoft proxy which requires NTLM authorization.
Things worked fine in Firefox 0.9.3 once the initial password for the proxy was
confirmed. Firefox 1.0pre does show the right password in the remembered
password lists, it just is not reused and each HTTP request triggers the
password prompt again.

Comment 3

13 years ago
please download and test Firefox 1.0rc1:
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.0rc1/

*** This bug has been marked as a duplicate of 256949 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.