Enable Firefox to auto-unzip a .zip file when downloading

RESOLVED DUPLICATE of bug 175008

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 175008
14 years ago
2 years ago

People

(Reporter: lukev123, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; rv:1.7.3) Gecko/20040913 Firefox/0.10

When downloading .zip (or any archive type) files it would be useful to
auto-unzip the archive into a specified directory. It's frustrating to have to
download the file and then start (or use) a 3rd party tool to extract the files.
It would be a great time-saver to have this feature.

Reproducible: Didn't try
Steps to Reproduce:
Suggestion:
1. Download the .zip file
2. Firefox asks you where to save the file, and if you want to unzip it into a
folder with the same name as the file, or a different folder name
3. You can save your choice as a default preference
4. Firefox downloads the archive and unzips the files into the specified directory 
Actual Results:  
N/a

Expected Results:  
Not able to do this at the moment.
Maybe as an extension, but I don't think this is something that we'd ship as a
default component, especially since we'd default it to off anyway.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 2

14 years ago
Yep.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit

Updated

9 years ago
Status: VERIFIED → RESOLVED
Last Resolved: 14 years ago9 years ago
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 175008

Comment 4

2 years ago
I disagree to default it to off, as well as having it as an extension. On Safari on Mac OS X the files unzip automatically so is there any reason why we couldn't have the same feature on Firefox? Once you get use to it, it's really hard to start unzipping every single file you download again...
You need to log in before you can comment on or make changes to this bug.