Status

VERIFIED WORKSFORME
14 years ago
6 years ago

People

(Reporter: tim, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
I clicked the firefox logo in the top-right corner of the UI.

I clicked the "developer" link on that page.

I got a 404 error.

Comment 1

14 years ago
Created attachment 159212 [details] [diff] [review]
patch (untested)

Comment 2

14 years ago
This is indeed correct. The link are wrong on the page. The patch basically adds
'../' before the link so they go another level deeper as required.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
Yeah, I just tested from in Mozilla :-)

* <http://www.mozilla.org/products/firefox/start/../../developer/>
* <http://www.mozilla.org/products/firefox/start/../../../developer/>

I'm not sure how he got to that page though...

Comment 5

14 years ago
try <a href="/developer/"> :-)

Comment 6

14 years ago
Using that people can't test offline anymore ;-). However, my Firefox redirects
as well...

Updated

14 years ago
Blocks: 254797

Updated

14 years ago
Blocks: 260326

Updated

14 years ago
No longer blocks: 260326
Depends on: 260326

Comment 7

14 years ago
The redirect is javascript. The page itself is a complete mess--old layout,
firefox 0.8 logo, bad links all over the place, and more.

Comment 8

14 years ago
*** Bug 263610 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 9

14 years ago
Why is this worksforme? The page is still there, still has the broken links, old
layout, etc., and the redirect's still broken for anyone who has javascript off.
We certainly need to do *something* about this page, though whether it's fixing
it or just deleting it and putting up an HTTP redirect, I don't know.

Comment 10

14 years ago
Just to confirm, I still get the 404!!
I'll attach a screen shot.

Comment 11

14 years ago
Created attachment 164277 [details]
404 screen shot

Comment 12

14 years ago
www.mozilla.org/products/firefox/start/ redirect should be live in a sec
Um, why was products/firefox/start/ made a *permanent* redirect?  We now have a
new page, but it will take users a long time to see it.  I had that set up very
carefully (with Cache-Control headers) so that users would revalidate the start
page on every startup.

You should have seen that I was responsible for a good bit of stuff on that page
and contacted me about it before doing that.

I've disabled stolenclover's CVS access because he's been warned about this
(contacting owners before breaking their stuff) many times before and failed to
shape up.
(Note that a temporary redirect would actually have been an improvement on the
old page, but it should have been obvious from the cvs logs that you should have
at least told me you were doing this, and probably asked me first.)
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.