File URIs in an e-mail message are not hyperlinked correctly

RESOLVED DUPLICATE of bug 241573

Status

MailNews Core
Attachments
RESOLVED DUPLICATE of bug 241573
13 years ago
9 years ago

People

(Reporter: J. P. Abelanet, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; IRIX64 IP35; en-US; rv:1.8a3) Gecko/R-A-C
Build Identifier: Mozilla/5.0 (X11; U; IRIX64 IP35; en-US; rv:1.8a3) Gecko/R-A-C

If an e-mail message contains, for example, "file:///usr/tmp/example.html", the
link is underlined and appears to be functional, but nothing happens when you
click on it.  If you "Copy Link Location" and then paste it into a Navigator
window, the file comes up properly.

Reproducible: Always
Steps to Reproduce:
1. Send an e-mail message to yourself containing the absolute path of a file on
disk.
2. Try to click on the highlited link in the Messenger pane.
3.

Actual Results:  
Nothing happens.

Expected Results:  
Should go to the referenced page.

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
no, this is still a problem - it may not warn if the referenced file does not
exist, but it does NOTHING when the file exists.  E-mails of this same format
work properly in Netscape 4.x, but are broken in Netscape 7.x as well.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

13 years ago
more info - if I take the exact content of the e-mail and put it into a page
that I view with a Navigator pane, it works properly.

I read the info in 84128, and at the very least the user needs to be notified
that for security reasons it will not perform the requested action, and that in
order to change this behavior the user needs to set:

user_pref("security.checkloaduri", false);

Comment 4

13 years ago
Before you go reopening this bug again, you have to realize: file: URLs are not 
going to be completely enabled in mail, and maybe not at all: bug 135830.  If 
you think they should be, vote for that bug; don't reopen this one.

*** This bug has been marked as a duplicate of 241573 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.